[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Apaceh2 with SSL and multiple virtual host



I have installed Apache webserver on a server machine.
I can browse the web pages using the ip address on the web browser.
But when I try to browse using the dns name of that server, it doesnt connect.

I m using static ip for the server.

Strange thing is if I do "ssh dns-name", that works.
But if I do http://dns-name/ that doesnt although it works with the ip address.

I have succcessfully set up the hostname of the server.

Please let me know what could be the possible problem.

Thanks,








On Thu, 25 Mar 2004 21:56:13 -0500
 "Reuben D. Budiardja" <techlist voyager phys utk edu> wrote:
> 
> Hi all,
> I am trying to set up Apache to work with SSL (https://...). I have apache2 
> and all the necessary packages from RHEL 3 distro.
> I followed the instruction here step by step to create the key, self-signed 
> certificate, etc:
> https://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/sysadmin-guide/s1-secureserver-accessingserver.html
> 
> The server started without any problem, but when I tried to use 
> https://www.mydomain1.com 
> 
> my mozilla browser gives me :
> "The connection to www.mydomain1.com has terminated unexpectedly. Some data 
> may have been transferred."
> 
> and on the server error_log: 
> Invalid method in request !g!!
> 
> I googled for that and tried everything that I found, and still did not work. 
> My setup is the following, i have 3 domain that points to this server, let's 
> just call them:
> www.mydomain1.com
> www.mydomain2.com
> www.mydomain3.com
> 
> So I set up VirtualHost in /etc/httpd/conf/httpd.conf for each of them. Now, I 
> only want www.mydomain3.com to be served securely as 
> https://www.mydomain3.com, while the other 2 just use the plain HTTP.
> 
> Is this possible at all ?  Also, I want any request to 
> http://www.mydomain3.com be automatically redirected to the corresponding 
> https address.
> 
> Another thing that I tried, is I copy the VirtualHost _default_ definition in 
> ssl.conf file, then replace it with the virtualhost info for mydomain3.com. 
> When I did that, https://www.mydomain3.com works, but trying to access: 
> http://www.mydomain2.com gives:
> 
> BAD REQUEST
> Your browser sent a request that this server could not understand. Reason: 
> You're speaking plain HTTP to an SSL-enabled server port. Instead use the 
> HTTPS scheme to access this URL,  please.
> Hint: https://www.mydomain3.com
> 
> So I'm utterly confused. Any help will be greatly appreciated.
> 
> Thanks
> RDB
> -- 
> Reuben D. Budiardja
> Department of Physics and Astronomy
> The University of Tennessee, Knoxville, TN
> ---------------------------------------------------------
> "To be a nemesis, you have to actively try to destroy 
> something, don't you? Really, I'm not out to destroy 
> Microsoft. That will just be a completely unintentional 
> side effect."
>                  - Linus Torvalds -
> 
> 
> -- 
> redhat-list mailing list
> unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
> https://www.redhat.com/mailman/listinfo/redhat-list

- Bikram
Database Specialist, WKU
http://www.wku.edu/~bikram.assal/




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]