[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Apaceh2 with SSL and multiple virtual host



The most commong cause, IMHO, of the error you are seeing Reuben is that nowhere in the plethora of .conf files for apache2 do you have an entry telling apache which SSL server certificate to use. Make sure that somewhere in your effective .conf files, you have an entry like below:

SSLCertificateFile <full path and name of your server certificate file>

Hope this helps,

--Moby

They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety.  -- Benjamin Franklin

First they came for the Jews and I did not speak out because I was not a Jew.
Then they came for the Communists and I did not speak out because I was not a Communist.
Then they came for the trade unionists and I did not speak out because I was not a trade unionist.
Then they came for me and there was no one left to speak out for me. -- Pastor Martin Niemöller


Reuben D. Budiardja wrote:

Hi all,
I am trying to set up Apache to work with SSL (https://...). I have apache2 and all the necessary packages from RHEL 3 distro. I followed the instruction here step by step to create the key, self-signed certificate, etc:
https://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/sysadmin-guide/s1-secureserver-accessingserver.html

The server started without any problem, but when I tried to use https://www.mydomain1.com
my mozilla browser gives me :
"The connection to www.mydomain1.com has terminated unexpectedly. Some data may have been transferred."

and on the server error_log: Invalid method in request !g!!

I googled for that and tried everything that I found, and still did not work. My setup is the following, i have 3 domain that points to this server, let's just call them:
www.mydomain1.com
www.mydomain2.com
www.mydomain3.com

So I set up VirtualHost in /etc/httpd/conf/httpd.conf for each of them. Now, I only want www.mydomain3.com to be served securely as https://www.mydomain3.com, while the other 2 just use the plain HTTP.

Is this possible at all ? Also, I want any request to http://www.mydomain3.com be automatically redirected to the corresponding https address.

Another thing that I tried, is I copy the VirtualHost _default_ definition in ssl.conf file, then replace it with the virtualhost info for mydomain3.com. When I did that, https://www.mydomain3.com works, but trying to access: http://www.mydomain2.com gives:

BAD REQUEST
Your browser sent a request that this server could not understand. Reason: You're speaking plain HTTP to an SSL-enabled server port. Instead use the HTTPS scheme to access this URL, please.
Hint: https://www.mydomain3.com

So I'm utterly confused. Any help will be greatly appreciated.

Thanks
RDB




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]