[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: install 2.6.4 kernel on rh8



Thank you for your reply, I did another attempt the way you described it, and as I can see it is getting close. Booting the 2.6.4 kernel gave kernel panic, but I think the reason is that I had not changed the .config file from CONFIG_EXT3_FS=m to CONFIG_EXT3_FS=y. Going back to 'make xconfig and make the building from there did not help, so I have deleted all directories made by the make commands and deleted all files made during the install in /boot and will try again tonight.

By the way, in your description you tell 'mv arch/i386/boot/bzImage /boot/bzImage-2.6.4' In current kernel 2.4.18 grub calls for vmlinuz-2.4.18-14. So if I 'cp /boot/bzImage /boot/vmlinuz-2.6.4' And /boot/grub/grub.conf have the lines:

kernel /boot/vmlinuz-2.6.4 ro root=LABEL=/ hdc=ide-scsi
   initrd /boot/initrd-2.6.4.img

.........it should be correct, or am I mistaken?? This was what I did, and the kernel starts to load until I get (taken from memory, as I am not at the actual box right now) 'error: pivot:: xxxxxxxxxxxxx kernel panic no init found.' A manual I found for the 2.6.4 kernel mentioned this problem as a result of CONFIG_EXT3_FS=m in the .config file




Manuel Arostegui Ramirez wrote:

--- Paal Marker <paal barum folkebibl no> escribió: >
OK, I tried to install from /usr/src/  and it seemed
to install ok. But still, no img files installed under /boot /boot/vmlinuz-2.6.4 should have been installed when the make command was
executed, right?


Try to make your .img with mkintrd in your
/usr/src/linux-2.6.4 and then copy it to /boot

Cheers

Manuel Arostegui Ramirez wrote:

--- Paal Marker <paalma online no> escribió: >   I
have big problems on this issue. My original


kernel is 2.4.18-14. I do not get any image files installed in /boot and neither /boot/grub/grub.conf or /etc/grub.conf are
updated
when installing kernel 2.6.4. If anyone has done this upgrade and have time to follow the steps I have done, I would be happy to know
what
I have done wrong.

The steps I have done is:


downloaded kernel linux 2.6.4.tar.gz
downloaded module-init-tools-3.0-pre10.tar.gz
downloaded modutils-2.4.21-23.src.rpm

tar xvfz module-init-tools-3.0-pre10.tar.gz
cd module-init-tools-3.0-pre10
./configure --prefix=/sbin
make
make install
./generate-modprobe.conf /etc/modprobe.conf

Installing modutils-2.4.21-23.src.rpm:
rpm -i modutils-2.4.21-23.src.rpm
rpmbuild -bb /usr/src/redhat/SPECS//modutils.spec
rpm -Fi

/usr/src/redhat/RPMS/i386/modutils-2.4.21-23.i386.rpm


Installing the kernel: (used directory
/home/src/kernel)
gunzip linux-2.6.4.tar.gz
tar xvf linux-2.6.4.tar
cd linux-2.6.4

Making /home/src/kernel/linux-2.6.4/.config
cp
/usr/src/linux-2.4/configs/kernel-2.4.18-686.config
/home/src/kernel/linux-2.6-3/.config
make oldconfig

edited line in .config, CONFIG_EXT3_FS=m to
CONFIG_EXT3_FS=y
Edited the Makefile:  EXTRAVERSION = -skim-ch6
make bzImage
make modules
make modules_install
make install
mkdir /sys

Editing /etc/rc.sysinit:
After line 'action $"Mounting proc filesystem: "
mount -n -t proc /proc /proc' put in line 'action $"Mounting sysfs filesystem: " mount -n -t sysfs /sys /sys'

After failing I tried to edit the .config file
'CONFIG_BLK_DEV_SD=y and then run:
make bzImage
make modules
make modules_install
make install
This did not make any difference.

Contents of /boot:

boot.b
chain.b
config-2.4.18-14
config-2.4.18-14debug
config-2.4.18-14uml
grub
initrd-2.4.18-14debug.img
initrd-2.4.18-14.img
kernel.h
lost+found
message
message.ja
module-info
module-info-2.4.18-14
module-info-2.4.18-14debug
module-info-2.4.18-14uml
os2_d.b
System.map
System.map-2.4.18-14
System.map-2.4.18-14debug
System.map-2.4.18-14uml
vmlinux-2.4.18-14
vmlinux-2.4.18-14debug
vmlinuz
vmlinuz-2.4.18-14
vmlinuz-2.4.18-14debug
vmlinuz-2.4.18-14uml
I install 2.6.4 on a RH9 and these were my steps.

Put my linux-2.6.4.tar.gz on /usr/src

tar -zxvf linux-2.6.4.tar.gz && cd linux-2.6.4
make xconfig
(When xconfig finished)
make && make modules && make modules_install
mv arch/i386/boot/bzImage /boot/bzImage-2.6.4
mv System.map /boot/System.map-2.6.4
ln -s System.map-2.6.4 System.map

Then I reconfigure my /etc/lilo.conf
I don't use grub, so I cannot help you on this
step.
Best regards

=====
--

Manuel Aróstegui Linux user 200896
http://manuel.todo-linux.com

___________________________________________________
Yahoo! Messenger - Nueva versión GRATIS
Super Webcam, voz, caritas animadas, y más...
http://messenger.yahoo.es




--
redhat-list mailing list
unsubscribe

mailto:redhat-list-request redhat com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list

=====
--

Manuel Aróstegui Linux user 200896
http://manuel.todo-linux.com

___________________________________________________
Yahoo! Messenger - Nueva versión GRATIS
Super Webcam, voz, caritas animadas, y más...
http://messenger.yahoo.es






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]