[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

up2date failure



I recently re-loaded my system, registered it with rhn_register
and tried to do 'up2date' on it.  As it was processing the RPM
Headers, during one of the XFree86 Fonts I believe, I got the
following message in the xterm window I ran it from:

SSL exception (104, 'Connection reset b
y peer')
SSL exception (-1, 'Unexpected EOF')
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1175, in onChannelsPageNext
    self.pkgList = self.pList.getPackagesToInstall()
  File "/usr/share/rhn/up2date_client/packageList.py", line 308, in getPackagesT
oInstall
    result = self.__skipPackages(result)
  File "/usr/share/rhn/up2date_client/packageList.py", line 336, in __skipPackag
es
    packageList = self.__skipFiles(packageList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 357, in __skipFiles
    ignoreMsgCallback = self.ignoreMsgCallback)
  File "/usr/share/rhn/up2date_client/packageList.py", line 416, in buildHeaderL
ist
    hdr = headerList[pkg]
  File "/usr/share/rhn/up2date_client/headers.py", line 121, in __getitem__
    self.__retrievePackage(item)
  File "/usr/share/rhn/up2date_client/headers.py", line 126, in __retrievePackag
e
    hdr, sourceType = rpcServer.doCall(rpmSource.psc.headerSource.getHeader, ite
m)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 114, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 239, in getHeader
    header = source.getHeader(pkg, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 677, in getHeader
    saveHeader(hdr)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 130, in saveHeader
    fileName = "%s/%s.%s.hdr" % (cfg["storageDir"],
TypeError: unsubscriptable object
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1218, in onSkippedPagePrepar
e
    maxlength = max(map(lambda x: len(x[0][0]), self.skipPkgList)) * 8
ValueError: min() or max() arg is an empty sequence

I used the latest up2date rpm's from redhats site after I reloaded the
system, so as far as I know, Im updated for everything I need.

Any help is appreciated,
thanks,
Jeff




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]