[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Help needed regarding rpm error.



Hi,all

I am using rh 9.0. Today I tried to install some rpm package,but I failed. Then I looked at the rpm command. It seems that rpm is corrupted. If I use the normal user, I can use rpm,but if I use root,I can't. Why? and do I need to rebuild the rpm db? and how?

[dingli condense dingli]$ rpm -qa | grep vsftpd
vsftpd-1.1.3-8
[dingli condense dingli]$ su -
[root condense root]# rpm -qa | grep vsftpd
rpmdb: fatal region error detected; run recovery
error: db4 error(-30982) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 -  (-30982)
error: cannot open Packages database in /var/lib/rpm
[root condense root]#


Thanks

Ding




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]