[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Building a kernel from source on RH9



|> 
|> Be careful, your grub.conf contains 2.4.28smp and your work 2.4.28. 
|> What is your choice ?
|> Here is my way :
|> If root=LABEL=/ is right with 2.4.20-37, it will be right with 
|> 2.4.28smp. If not, you can replace it by root=/dev/hdan (n is the 
|> number of your root partition)
|> You have to clean all like this (don't write the comments (...)) :
|>  
|> 1) Edit Makefile and adapt "EXTRAVERSION = smp" or "EXTRAVERSION =", 
|> the result will be seen in /lib/modules/2.4.28smp or 
|> /lib/modules/2.4.28
|> You know that smp corresponds to multi processor (see with make 
|> xconfig)
|> 2) cp .config /tmp/.config
|> 3) make mrproper    (to wash your src directories ;-))
|> 4) cp /tmp/.config .config
|> 5) make xconfig    (correct variable multi processing, you need it 
|> with hyperthreading)
|> 6) make dep    (you forgot it ?)
|> 7) make clean   (a little wash more)
|> 8) make bzImage   (here is kernel)
|> 9) make modules    (all the .o)
|> 10) make modules_install  (results in /lib/modules/2.4.28smp)
|> 11) cp arch/i386/boot/bzImage /boot/vmlinuz-2.4.28smp
|> 12) cp System.map /boot/System.map-2.4.28smp
|> 13) cd /boot
|> 14) mv initrd-2.4.28smp.img initrd-2.4.28smp.old  (case if next 
|> mkinitrd crash)
|> 14) mkinitrd initrd-2.4.28smp.img 2.4.28smp
|> 15) edit grub/grub.conf if you need it (with vmlinuz-2.4.28smp and 
|> initrd-2.4.28sp.img)
|>  
|> Then, if you still Panic, you have to review "make xconfig"
|>  
|> Patrick - rhce
|> 
|> 

I actually did do step 6, just left it out of my initial message. 

So here is what I did now:

I edited the Makefile and added 'smp' to 'EXTRAVERSION='. I ran 
'make mrproper'. Then I ran 'make xconfig'. I selected 'load from 
file' and I loaded the config file 
/usr/src/linux-2.4.20-31.9/configs/kernel-2.4.20-i686-smp.config.
I then did a 'save and exit'.

At the 'make modules' step, the compile bombed on the decnet module.
So I re-ran 'make xconfig' and turned off decnet. Then re-ran 'make 
dep', 'make clean', 'make bzImage', and 'make modules'. Now at the 
'make modules_install' step I get this:

cd /lib/modules/2.4.28smp; \
mkdir -p pcmcia; \
find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{} 
pcmcia
if [ -r System.map ]; then /sbin/depmod -ae -F System.map  2.4.28smp; fi
depmod: *** Unresolved symbols in 
/lib/modules/2.4.28smp/kernel/crypto/autoload.o
depmod:         crypto_alg_lookup
depmod: *** Unresolved symbols in 
/lib/modules/2.4.28smp/kernel/crypto/proc.o
depmod:         crypto_alg_sem
depmod:         crypto_alg_list

Help please.

Barry



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]