[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Missing packages



On Mon, 17 Jan 2005 13:16:11 +1300, Gavin Young wrote:

> I get the exact same problem. I'd love to know a fix for this.
> 
> On Sun, 2005-01-16 at 17:52 -0600, Bruce Wilkinson wrote:
> > I'm using Add or Remove Packages, trying to install any of the
> > development tools. In each case, I get "Packages Not Found" error. The
> > occurs with all of development packages, although the missing packages
> > differ slightly.
> > 
> > Some of the frequent missing packages are libselinux, krb5-libs, pam,
> > libxml2. Oddly enough, if I go get those packages and try to install
> > them, I get an error indicating the packages are already installed.
> > 
> > Does anyone know what's wrong?
>
> I get the exact same problem. I'd love to know a fix for this.

The utility is not capable enough and is confused by installed errata
packages. That means, an installed package is newer than the -devel
package to be installed. But a -devel package depends on a strict
version of its mother package. This has been reported before, and only
future feature enhancements will fix it for good.

The work-around is to use up2date (or yum) to install all packages
which cause trouble. For example, in your case:

  up2date krb5-devel libselinux-devel pam-devel libxml2-devel

And then proceed with the graphical tool, if need be.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]