[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Enabling SWAT problem



Thank you for your sincerity, but that's what I wanted to do - to install somelike a full package.
Unfortunately, I got from samba.org the "samba-2.2.12.tar.gz" file, unzipped and compiled the sources from the "Sources" directory.
I took this file from samba 'cause with the samba packages from the RedHat disks I had the same problem - no SWAT -  and thought that with such a file from samba I will solve everything.
Now, where can I get all the suite from ?

>>> Mike Burger <mburger bubbanfriends org> 01/22/05 21:45 PM >>>
I hope you'll pardon my blunt response, here, but this was your first 
problem.  Red Hat already packages up the entire samba suite in RPMs, 
suitable for immediate installation and use.

*MY* suggestion is to install the samba-swat package (easiest way if 
running something recent, is "up2date samba-swat"), although, if I were 
you, I'd reinstall the entire samba suite from RPM, to make life easier.

The 3 packages you'll need are:

samba
samba-common
samba-swat

Optionally, if you want to connect to other Samba/Windows resources, you 
can install:

samba-client

On Sat, 22 Jan 2005, Aram Hazarian wrote:

> Nope, running ?rpm ?q samba-swat? tells me that I don?t have it installed.
> Did I have something more to do when compiling samba in order to have SWAT functional ?
> In the README file writes only the steps I followed ? swat in services, then in xinetd.conf, ? but no success.
> 
> On the other hand, I searched also with nmap and:
> 
> [root bobo sbin]# nmap -p 901 127.0.0.1
> 
> Starting nmap 3.75 ( http://www.insecure.org/nmap/ ) at 2005-01-22 17:09 EET
> Interesting ports on bobo (127.0.0.1):
> PORT    STATE  SERVICE
> 901/tcp closed samba-swat
> 
> It appears that I have missed something and there is no swat service alive. I have to search for a package appart, only with SWAT ?
> 
> Thanks
> 
> 
> >>> mburger bubbanfriends org 01/21/05 22:05 PM >>>
> Seems like you've duplicated your efforts.
> 
> However, the big question, since you say that there was no swat file in 
> /etc/xinetd.d, is this:
> 
> Is the samba-swat package installed?
> 
> rpm -q samba-swat
> 
> On Fri, 21 Jan 2005, Aram Hazarian wrote:
> 
> > Hi,
> > 
> > What about my issue:
> > 
> > I installed samba 2.2.12.
> > 
> > I added in /etc/services the line:
> > swat	901/tcp   (uncommented)
> > 
> > I added in /etc/xinetd.conf the line:
> > swat	stream	tcp	nowait.400   root   /usr/local/samba/bin/swat   swat
> > 
> > Because in /etc/xinetd.d there was no ?swat? file, I created one with the following content:
> > service swat
> > {
> > 	disable	= no
> > 	port=901
> > 	socket_type=stream
> > 	wait=no
> > 	only_from=127.0.0.1
> > 	user=root
> > }
> > 
> > I restarted xinetd ? and when I went in the browser, at http://127.0.0.1:901 the only answer I got is ?The connection was refused when trying to connect to ?? !!!
> > 
> > By the way, I have httpd started.
> > 
> > Everything looks like swat is not recognized as a service for the system.
> > I tried also:
> > [root bobo sbin]# ./service swat start
> > swat: unrecognized service
> > 
> > I feel like stucked ?
> > 
> > I would appreciate your help.
> > 
> > Thanks,
> > 
> > Bobo
> > 
> > 
> > 
> 
> 

-- 
Mike Burger
http://www.bubbanfriends.org

Visit the Dog Pound II BBS
telnet://dogpound2.citadel.org or http://dogpound2.citadel.org

To be notified of updates to the web site, visit 
http://www.bubbanfriends.org/mailman/listinfo/site-update, or send a 
message to:

site-update-request bubbanfriends org

with a message of: 

subscribe




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]