[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Is anyone on the list using "formmail" CGI script on their RH Apache implementations?



On Jan 26, 2005, at 9:47 AM, Sebastijan Petrovic wrote:

I've been using FormMail (well known, I'm sure) CGI script on my Apache
servers for 5-6 years and never had a problem.

I recently upgraded from RH9 to FC2 and FormMail no longer works.
Rather, I keep getting 500 errors on the server.

I tested the script from command line and it's fine, the path to the
script is good as well as the permissions.

How did you test it?  What was the output?

When I review error_log for Apache it shows Premature end of script
headers: FormMail.pl

I wonder if the issue is a version of the Perl, on FC2 it's version 5.9
and on RH9 I run 5.8.

I know there are bunch of sites out-there specific to CGI and perl
issues, but I've been unable to locate decent help.

PerlMonks (http://www.perlmonks.org) is a fantastic site for Perl programmers, but not necessarily for application debugging. Your first avenue should always be the application support forum/list.

If someone is familiar with the script but uses something else instead
(i.e. Java script) please suggest it.

I don't use FormMail.pl. As best I recall, it has had a history of security holes. I imagine it would be quite simple to whip up an alternate solution in Perl.

--
Jason Dixon
DixonGroup Consulting
http://www.dixongroup.net




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]