[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Is anyone on the list using "formmail" CGI script on their RH Apache implementations?



Michael Schwendt wrote:
On Wed, 26 Jan 2005 09:54:54 -0500, Sebastijan Petrovic wrote:


I've been using FormMail (well known, I'm sure) CGI script on my Apache
servers for 5-6 years and never had a problem.

I recently upgraded from RH9 to FC2 and FormMail no longer works.
Rather, I keep getting 500 errors on the server.

I tested the script from command line and it's fine, the path to the
script is good as well as the permissions.

When I review error_log for Apache it shows Premature end of script
headers: FormMail.pl

I wonder if the issue is a version of the Perl, on FC2 it's version 5.9
and on RH9 I run 5.8.


Premature end of script headers is a topic covered in quite a detail by
the Apache FAQ. Start trouble-shooting with the information provided
there, as there are several reasons why a script can fail with that
error.


I had this happen to me (different perl script) when my perl was installed in a different directory than what was stated on the first line of the script. Perhaps that is the problem. It could be many other things tho..

-Jim



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]