[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: LD_LIBRARY_PATH Issue



Did you check your ld.so.conf file to verify the path entry exists there?
If it does not, edit the file and put it in there, then run ldconfig.

-----Original Message-----
From: Simran H. [mailto:redhat chamkila org]
Sent: Monday, January 31, 2005 9:41 AM
To: redhat-list redhat com
Subject: LD_LIBRARY_PATH Issue


Hi Guys,

I have a application running on my system that I am having some problems
with.  If I telnet to my server and run the application then I get the
following library errors:

Fatal Error: Cannot Successfully map soname 'libpdb.so' under any of the
filenames
/usr/lib32/libpdb.so:/usr/lib32/internal/libpdb.so:/lib32/libpdb.so:/opt/lib
32/libpdb.so:

The library that it is looking for is in the following location:
/usr/unsupported/schrodinger/maestro-v65007/lib/

When I run the app I see that the LD_LIBRARY_PATH is set to:
LD_LIBRARY_PATH:
/usr/unsupported/schrodinger/maestro-v65007/lib/:/usr/unsupported/schrodinge
r/maestro-v65007/lib/:

If I link the required libs to /usr/lib32 then this works but I need a
better fix for this issue.

----

However, if I do a "su - unixid" I am able to successfully run the
application without any problems and the LD_LIBRARY_PATH is set to:

LD_LIBRARY_PATH: /usr/unsupported/schrodinger/maestro-v65007/lib/:

----

Any idea as to why this might be happening and how can I fix this issue?

Thanks in advance.
-Simran

-- 
redhat-list mailing list
unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]