[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: uninstall mysql in linux redhat



On Sun, 2005-06-19 at 11:48 +0000, H.A.G. wrote:
> Now I found one package using this command:
> # rpm -qa | grep -i mysql
> output: MySQL-server-standard-5.0.7-0.rhel3.i386.rpm
> 
> When I tried to remove this package it gave error:
> # rpm -ivh MySQL-server-standard-5.0.7-0.rhel3
> error occurred in service mysql: file or directory are not
> available
> Error: %preun(MySQL-server-standard-5.0.7-0.rhel3) scriptlet
> failed, exit status 1
> 
> And when I tried to install this package again, it gave error:
> output: # rpm -ivh MySQL-server-standard-5.0.7-0.rhel3.i386.rpm
> 
> MySQL-server-standard-5.0.7-0.rhel3 is already installed
> 
> So I can not remove this package and I can not reinstall it.
> 
> Any idea.

Hi there. Who supplied the MySql package you are using, BTW?

On RHEL3 you can do this:

rpm -qa MySQL\*

to do a 'globb' search for packages that begin with MySQL, instead of
the grep. 

I assume that you did a typo' and meant to show that you are doing 'rpm
-e'

The failure you see is due to a script that is being run by the rpm
erase command failing, in the %preun section of the RPM's spec file.

I suggest that you investigate what the preun scripts are that are being
run. You can view them using :

rpm -q --scripts MySQL-server-standard

It may give you a clue as to why it is failing. If you find that the
preun script is not particularly important, you can do the erase with an
option --nopreun  ie:

rpm -e --nopreun MySQL-server-standard

This does the RPM package erase without running the preun scriptlet.

More information is in the manual page of RPM  :

man rpm

Cheers,
Michael






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]