[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: System keeps dropping into shell.



It didn't say that. Anyway, I've tried fsck using different hda number but it didn't work.

Instead, it said that fstab did not contain fsck passno field. (1st warning shown). I guess it then tried to fsck for me, stating
fsck.ext2/ :
Then it said "The superblock could not be read or does not describe a correct ext2 filesystem ... try running e2fsck with alternate superblock :
  e2fsck -b 8193 <device>
I've tried e2fsck like stated on screen with different hda. How many superblocks are there? I'll check the different hda starting blocks again but I doubt it will work. What if the filesystem is using ext3?

What error report? I know dmesg but it is in /var/log which is empty.

YYOng


Alfred Hovdestad wrote:

It sounds like your system is detecting a file system error which the boot-up check cannot repair. It should say something like:

fsck /dev/hda1

where /dev/hda1 is where your / or /boot partition is mounted. If you type the command as shown when you drop down to the shell, you should be able to repair the filesystem. If you can post the error reported from another computer, it should be easier to analyze your problem (unless your hard drive died).

   Alfred Hovdestad





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]