[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: System keeps dropping into shell.



No such error message.

I added the CDRW long before this. Incorrect device name, no, but maybe fsck incorrect filesystem type. The error did say something about ext2 filesystem and I think it tried to fsck ext2 / for me but it failed. I guess the system is ext3 not ext2. I didn't install that system. So, what can be done?

I have tried going into rescue mode using the installation CD but /etc seemed to be empty. No fstab. In fact, it was worse than logging into shell.

Logging into shell at the error is better as it has everything (I guess) in /bin, /etc, /root, /sbin and /mnt. Though fstab is there, it has nothing inside.

I guess the links are gone (whoops) or corrupted and I don't know how to recover them. :-( I'll have to try to run the system in this state like mounting the CDRW and backing some data. Cannot chmod so I guess cannot mount too but can shutdown.

The worst and last solutions, reinstall unless some one has a solution. Thanks anyway.

YYOng

Mindy Preston wrote:

Ong,

There should be a line that tells you exactly what you need to do when fsck fails. Something like, "automated fsck failed - run manually with 'fsck -f /dev/sda1'" (with a different device, most probably). The reason your directories are empty is that they aren't being mounted - the system is mounting only the root filesystem for repairs. You can't, and shouldn't, run the system in this state.

If fsck'ing devices doesn't work, you may have a filesystem in /etc/fstab that shouldn't be there, or has an incorrect device name. Have you removed or added any hard disks to the system recently? Have you rearranged any? These can all cause problems with /etc/fstab. If you suspect this might be the case, you should boot the system with the Redhat rescue disk (I know you said you didn't have it, but you could download and burn it) or the LiveCD of your choice (Morphix, Knoppix, etc.) and edit /etc/fstab so that it reflects reality.

Hope this helps,
Mindy






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]