[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mii-tool discrepincy



On 6/27/05, Smith, Albert <Albert Smith genexservices com> wrote:
> Hey folks,
> 
>    I just want to make sure that I am not the only one having this
> problem.
> 
> net-tools-1.60-20E.7
> 
> mii-tool is detecting the card at 100FD but ethtool is seeing the card
> at 1gig. DMESG shows the link set to 1gig. If I have mii-tool
> autonegotiate the card again it says that it's 100FD but dmesg states
> 1gig and ethtool states 1gig. Does mii-tool support 1gig?

Don't know for sure but the mii-tool manpage and help suggest that it doesn't.

usage: mii-tool [-VvRrwl] [-A media,... | -F media] [interface ...]
       -V, --version               display version information
       -v, --verbose               more verbose output
       -R, --reset                 reset MII to poweron state
       -r, --restart               restart autonegotiation
       -w, --watch                 monitor for link status changes
       -l, --log                   with -w, write events to syslog
       -A, --advertise=media,...   advertise only specified media
       -F, --force=media           force specified media technology
media: 100baseT4, 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD,
       (to advertise both HD and FD) 100baseTx, 10baseT

So I'm guessing mii-tool is 10/100.

John



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]