[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

version GLIBC_2.0 not defined in file libc.so.6 with link time reference



Hello All,

I have installed Glibc-2.3.5 over Glibc-2.1.92. And after that, few of
my packages gave error-

"version GLIBC_2.0 not defined in file libc.so.6 with link time reference"

To resolve this, I reinstalled those packages against my current
library and they are working fine. But now, on trying to re-install X
windows, I am getting few errors which are related to GLIBC_2.0.

Now, if i run the following command on libc.so.6:

nm libc.so.6 | grep 'A GLIBC_2'

I get the following result:

00000000 A GLIBC_2.0
00000000 A GLIBC_2.1
00000000 A GLIBC_2.1.1
00000000 A GLIBC_2.1.2
00000000 A GLIBC_2.1.3
00000000 A GLIBC_2.2
00000000 A GLIBC_2.2.1
00000000 A GLIBC_2.2.2
00000000 A GLIBC_2.2.3
00000000 A GLIBC_2.2.4
00000000 A GLIBC_2.2.6
00000000 A GLIBC_2.3
00000000 A GLIBC_2.3.2
00000000 A GLIBC_2.3.3
00000000 A GLIBC_2.3.4

So, that means the symbol is defined in libc.so.6. Then why I am
getting this error?

Hope to receive replies from you.

Regards,
Nupur.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]