[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Help with ES v3 Raid1 (Mirror)



This worked, but I had an issue. I'll explain. I ran your process and
after step 8 I was able to mount this device and write to it. after
re-booting it failed during start-up with the same error. The only thing
that I can see is that if you set the 1 2 option in the fstab it tells
the system to run fsck at boot. when this runs it seems to distroy
something, because when I remove the line in fstab and reboot, I can no
longer mount it because of wrong fs type.

I will re-run your process but use 0 0 in fstab before restarting.

Marc

On Wed, 2006-02-01 at 17:20 -0200, Cleber P. de Souza wrote:
> Hi Marc.
> 
> I think you forgot somethings.
> After you fdisk a disk, you must restart the system so the new changes
> have efect.
> So I suggest you follow this steps:
> 
> 1) fdisk sdb setting fd to the partition, as you did;
> 2) restart the system;
> 3) execute sfdisk -d /dev/sdb | sfdisk /dev/sdc (copy partition
> structure from sdb to sdc);
> 4) restart again;
> 5) run the command to make the raid devices (mdadm ...), as you did;
> 6) mkfs.ext3 /dev/md0
> 7) e2fsck -f /dev/md0
> 8) add lin in fstab.
> 
> Ready.
> 
> 
> 
> On 2/1/06, Marc Leveille <marc leveille nrc-cnrc gc ca> wrote:
> > I have tried this all morning without success. I also tried making the
> > raid device using sdb1 and sdc1 as oppesed to sdb and sdc. Here is what
> > I am doing in exact steps because sometimes one little thing can mess
> > things up.
> >
> > 1- Fdisk sdb and create a primary partition with full size of drive and
> > set type to FD (Linux Raid). write and exit
> > 2- same as step 1 but for sdc.
> > 3- run the command to make raid device. "mdadm --create /dev/md0
> > --level=1 --raid-devices=2 /dev/sdb1 /dev/sdc1
> > 4- mkfs.ext3 /dev/md0 (completes with noe errors)
> > 5- e2fsck -f /dev/md0 (works with no errors)
> > 6- add line in fstab
> > /dev/md0   /home/apps  ext3    defaults  1 2
> >
> > reboot and get
> >    FSCK.ext3 /dev/mdo the superblock could not be read or does not
> > describe a correct EXT2 Filesystem.......bla bla and asks to run E2FSCK
> > -B 8193
> >
> > e2fsck: invalid arguement whilt trying to open /dev/md0
> >
> > thanks
> >
> > Marc
> >
> > On Wed, 2006-02-01 at 13:40 -0200, Cleber P. de Souza wrote:
> > > OK.
> > > Put your success of failure here later.
> > > I had this problem one time making raid from a existing Red Hat system
> > > and solve in this way.
> > >
> > > On 2/1/06, Marc Leveille <marc leveille nrc-cnrc gc ca> wrote:
> > > > Hi, I never ran e2fsck -f /dev/md0 after making fs on /dev/md0.
> > > >
> > > > I will try this this morning.
> > > >
> > > > Marc
> > > >
> > > > On Wed, 2006-02-01 at 10:15 -0200, Cleber P. de Souza wrote:
> > > > > Hi Marc.
> > > > >
> > > > > After run mdadm --create you must also run mkfs.ext3 /dev/md0 and
> > > > > e2fsck -f /dev/md0.
> > > > > So you will get OK.
> > > > >
> > > > >
> > > > >
> > > > > On 1/26/06, Marc Leveille <marc leveille nrc-cnrc gc ca> wrote:
> > > > > > Hi, I'm trying to setup a Raid1 mirror between 2 hard drives. I have the
> > > > > > following.
> > > > > >
> > > > > > 1- SDA 36gig System disk
> > > > > > 2- SDB 36gig blank
> > > > > > 3- SDC 36gig blank
> > > > > >
> > > > > > I'm trying to Mirror SDB to SDC by doing the following.
> > > > > >
> > > > > > 1- By using FDisk I created SDB1 and SDC1 on each drive.
> > > > > > 2- I then makefs ext3 for each partition.
> > > > > > 3- Then I used mkadm --create /dev/md0 --level=1
> > > > > > --raid-devices=2 /dev/sdb1 /dev/sdc1
> > > > > >
> > > > > > I ran watch cat /proc/mdstat until the process was completed.
> > > > > > 4- when it was complete I tested the mount using mount -t
> > > > > > ext3 /dev/md0 /home/apps and it mounted and I was able to open it.
> > > > > > 5- I then edited fstab with /dev/md0 /home/apps ext3 defaults 1 2 and
> > > > > > rebooted.
> > > > > > 6- I now get the following error at boot.
> > > > > >
> > > > > > FSCK.ext3 /dev/mdo the superblock could not be read or does not describe
> > > > > > a correct EXT2 Filesystem.......bla bla and asks to run E2FSCK -B 8193
> > > > > >
> > > > > > 7- I used Vi and comented out the mount in fstab and re-booted. I tried
> > > > > > to manually mount the drive the same way as (Item #4) and it now fails
> > > > > > Mount: Wrong FS Type.
> > > > > >
> > > > > > Any ideas as to what I need to do. Sould I use ext3 ?
> > > > > >
> > > > > > thanks
> > > > > >
> > > > > > Marc
> > > > > >
> > > > > > --
> > > > > > redhat-list mailing list
> > > > > > unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
> > > > > > https://www.redhat.com/mailman/listinfo/redhat-list
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Cleber P. de Souza
> > > > >
> > > >
> > > > --
> > > > redhat-list mailing list
> > > > unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
> > > > https://www.redhat.com/mailman/listinfo/redhat-list
> > > >
> > >
> > >
> > > --
> > > Cleber P. de Souza
> > >
> >
> > --
> > redhat-list mailing list
> > unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
> > https://www.redhat.com/mailman/listinfo/redhat-list
> >
> 
> 
> --
> Cleber P. de Souza
> 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]