[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Help with ES v3 Raid1 (Mirror)



Hi Marc,

The reason your software RAID is not starting automatically on boot is because you need to remake your initrd image. I have had this same issue before and it is easy to fix. From the title of your post I assume you are running RHEL ES v3. With your software RAID running (i.e. "cat /proc/mdstat" shows md0) run this command as root:

mkinitrd -f "/boot/initrd-`uname -r`.img" "`uname -r`"

This will recreate the initrd image and will allow software RAID 1 to start on boot. Then you can remove the:

mdadm --assemble --scan /dev/md0
mount -t ext3 /dev/md0 /home/apps

from rc.local and remove the noauto from the fstab.

--
Ryan Enge
System Administrator
University of Victoria
Room: CLE D046 Phone: 472-5447
Email: renge uvic ca

Thanks this solved things. Here is my recap. It seems that I was chasing "witch came first, the chicken or the egg". I will try to explain as best as I can.

When running the procedure in previous posts, it would get me to work only after creating the /dev/md0 device, witch I could mount and use till I re-booted.

Now, the interesting part.
while trying to run mdadm --detail --scan > /etc/mdadm.conf would fail because mdadm was not started. So no config file no start. I rebuilt the device, but before re-booting I ran the command and it populated the mdadm.conf file except for my DEVICE /dev/sdb1 /dev/sdc1 Line. I guess that after building md0 with mdadm, it actually starts mdadm. This explains why it only worked after a new build of md0. So now I have the mdadm.conf file and entered the following into rc.local

mdadm --assemble --scan /dev/md0
mount -t ext3 /dev/md0 /home/apps

I then got some errors at boot up because I had not set /dev/md0 in fstab to be noauto.

All is well now. Thanks to Cleber and Eric to have the patients to stick with me on this long one, but not all is lost as I have learned a lot through this whole thing. Even after 20 years in computers (only 3 with Linux) we learn new stuff.

Again many thanks

Marc



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]