[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Boot loader problem after addiing SCSI disk



Thanks Ed for your response.

The root partition on sdb1 has a label as "/" in the grub.conf.

Attached is a brief summary on the system, three disks, sda, sdb and
sdc.
I have also included the grub.conf file before any change.

Peter 
-----Original Message-----
From: redhat-list-bounces redhat com
[mailto:redhat-list-bounces redhat com] On Behalf Of Ed Wilts
Sent: 08 June 2006 12:41
To: General Red Hat Linux discussion list
Subject: Re: Boot loader problem after addiing SCSI disk

On Thu, Jun 08, 2006 at 08:50:08AM +0100, Chiu, PCM (Peter) wrote:
> I have hit a problem in booting up a RH 9 box after adding a SCSI
disk.
> 
> The boot process pauses after displaying:
> 
>   GRUB Loading stage 1.5
>   GRUB Loading, please wait...
> 
> The machine does not show any response, not even 
> Control-Alternate-Delete.
> 
> I boot off RH9 CD and started off Linux rescue mode.
> 
> I can see all the existing scsi disks as well as the new one - though 
> somehow, the new one becomes sda, and the old sda becomes sdb, and the

> old sdb becomes sdc.
> 
> I tried to reset the MBR with grub-install /dev/sdb but same result.
> 
> I have also tried replacing all references on hd0,0 to be hd1,0 in 
> grub.conf, and reapply grub-install /dev/sdb, still no joy.
> 
> Any idea anyone?

Do you have labels on your boot volumes?  grub should point to the
label.  e.g.
title Tao Linux (2.6.9-34.0.1.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-34.0.1.EL ro root=LABEL=/1 norhgb quiet
        initrd /initrd-2.6.9-34.0.1.EL.img

So make sure you've got both the correct root and LABEL options
correctly specified.

        .../Ed

--
Ed Wilts, RHCE
Mounds View, MN, USA
mailto:ewilts ewilts org
Member #1, Red Hat Community Ambassador Program

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]