[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Grub Loading Error 15



Hello all linux gurus,

Any assistance on the following would be greatly appreciated: The problem is
the following: 

I am kickstarting my machines setting up raid and LVM during the Kickstart
as well. This all seems to work beautifully, the raid config, LVM creation,
package install etc etc. but after all of the stuff is done and the first
reboot happens, I get the dreaded

Grub Loading Stage1.5.

grub Loading, please wait...
Error 15

If I now go reboot using the install CD, do "linux rescue", get into grub,
do the root (hdx,0) and setup (hdx) commands on both drives, it all works!

Any ideas why?

The key components of my ks.cfg are as follows: 

bootloader location=mbr [I've tried setting this to 'partition', but no go]
zerombr yes			[I've tried commenting this out, but no go]

part raid.01 --size=100 --asprimary --ondisk=sda
part raid.11 --size=100 --asprimary --ondisk=sdb
part raid.02 --size=10240 		--ondisk=sda
part raid.12 --size=10240 		--ondisk=sdb

raid /boot 	--fstype=ext3 --level=1 --device=md0 raid.01 raid.11
raid / 	--fstype=ext3 --level=1 --device=md1 raid.02 raid.12

and my grub.conf has:

title RHEL4U3 (2.6.9-34.ELsmp)
	root (hd0,0)
	kernel /vmlinuz-2.6.9-34.ELsmp ro root=/dev/md1
	initrd /initrd-2.6.9-34.ELsmp.img

What am I missing?
Anyone any ideas?





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]