[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Installing gtk+-2.8.9



I'm trying to install php-gtk-2.0.beta on a RHEL3 server.  I couldn't
really find rpm packages for the prerequisites' versions, so have been
compiling the prerequisites manually - oh dear...
 
So far I've compiled and installed (in this order):
 
glib-2.14.0
atk-1.10.3
cairo-1.2.6
pango-1.16.4
 
During this process I had to upgrade the following too:
 
automake-1.9.6
autoconf-2.61
pkg-config-0.22
 
Now I'm trying to get gtk+-2.8.9 to build.  When I run ./configure, it
tells me:
 
checking for BASE_DEPENDENCIES... configure: error: Package requirements
(glib-2.0 >= 2.7.1    atk >= 1.0.1    pango >= 1.9.0    cairo >= 0.9.2)
were not met.  Consider adjusting the PKG_CONFIG_PATH environment
variable if you installed software in a non-standard prefix.
 
So it doesn't think that any of those are installed...and I believe it
has something to do with pkg-config, and with the environment variables
that should be PKG_CONFIG_PATH=/usr/local/lib/pkgconfig (which it is),
and PKG_CONFIG=/usr/local/bin/pkg-config (which it is).
 
$ ls -l /usr/local/lib/pkgconfig
total 68
-rw-r--r--    1 root     root          261 Sep 25 13:48 atk.pc
-rw-r--r--    1 root     root          284 Sep 25 15:28 cairo-ft.pc
-rw-r--r--    1 root     root          360 Sep 25 15:28 cairo.pc
-rw-r--r--    1 root     root          228 Sep 25 15:28 cairo-pdf.pc
-rw-r--r--    1 root     root          233 Sep 25 15:28 cairo-png.pc
-rw-r--r--    1 root     root          234 Sep 25 15:28 cairo-ps.pc
-rw-r--r--    1 root     root          224 Sep 25 15:28 cairo-svg.pc
-rw-r--r--    1 root     root          285 Sep 25 15:28 cairo-xlib.pc
-rw-r--r--    1 root     root          262 Sep 25 15:28
cairo-xlib-xrender.pc
-rw-r--r--    1 root     root          336 Sep 25 10:16 glib-2.0.pc
-rw-r--r--    1 root     root          279 Sep 25 10:16 gmodule-2.0.pc
-rw-r--r--    1 root     root          279 Sep 25 10:16
gmodule-export-2.0.pc
-rw-r--r--    1 root     root          258 Sep 25 10:16
gmodule-no-export-2.0.pc
-rw-r--r--    1 root     root          246 Sep 25 10:16 gobject-2.0.pc
-rw-r--r--    1 root     root          246 Sep 25 10:16 gthread-2.0.pc
-rw-r--r--    1 root     root          316 Sep 25 15:49 pango.pc
-rw-r--r--    1 root     root          283 Sep 25 15:49 pangox.pc
 
$ /usr/local/bin/pkg-config --version
0.22
 
Am I right when I say that somehow I *just* need to get gtk+-2.8.9's
configure script to look in the right place?  I don't seem to have much
luck doing that, so would appreciate any advice on this.
 
Thanks very much.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]