[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: an authentication problem



Paula J. Lindsay wrote:
Hi everyone,
I just set up a RHE 4. I got it registered with RH and the updates going so I thought everything was fine. Then the lab called me back, they weren't able to log in. I looked at the messages and I see the people who tried to log in, which is everyone in
this particular lab, and they are all getting the same error:

Jan 4 10:32:45 leila sshd(pam_unix)[12276]: 2 more authentication failures; logname= uid=0 euid=0 tty=ssh ruser= rhost=serendipity user=felitsky

when myself or someone that is not in the lab logs in it is fine. Can anyone help me out. I've checked off the firewall, exported the users from their home directory, but it didn't fix the problem. Can any help me? Has this happened to anyone out there
in RH world?  Many thanks in advance for any help.
Paula


You may want to increase the log verbosity of sshd in order to see why it is failing.

in /etc/ssh/sshd_config look for

# obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
SyslogFacility AUTHPRIV
#LogLevel INFO

and uncomment the LogLevel and change it to DEBUG

then you need to edit /etc/syslog.conf and locate the 'AUTHPRIV' facility line and ensure it is something like

# The authpriv file has restricted access.
authpriv.*                                              /var/log/secure

or authpriv.debug if it doesnt have a *

Then restart syslogd and sshd (you'll only need to restart syslogd if you have changed the config file obviously) and then get someone to try logging in again, you should then see why the login is failing.

HTH,


--
Steve
()  ascii ribbon campaign - against html e-mail
/\  www.asciiribbon.org   - against proprietary attachments



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]