[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Out of Memory - continued






It looks like for some reason the swap space was not loading on boot, i
have now fix that but still get the "Out of Memory killed process". So i
think i need to look more into the Overcommit_memory settings and
Overcomitt_ratio. I have 2 gig of memory and 2 gig of swap, could any who
knows what would be a ideal setting for me to try i.e should i use
Overcommit_memory 1 or 2 and also what the ratio should be with the set-up
i have here. I have already tried the setting Overcomiit_memory=1 with
ratio 50 but it did not stop the errors. I have been trying to get this to
work for over a week now so any suggestions on the settings would be great.

Regards

Andrew Bridgeman
|+-----------------------------+------------------------------------------|
||   Ray Van Dolson            |                                          |
||   <rvandolson esri com>     |                                          |
||   Sent by:                  |   To:        redhat-list redhat com      |
||   redhat-list-bounces redhat|           cc:                            |
||   .com                      |           Subject:        Re: Out of     |
||                             |   Memory - continued                     |
||   23/01/2008 16:15          |                                          |
||   Please respond to General |                                          |
||   Red Hat Linux discussion  |                                          |
||   list                      |                                          |
||                             |                                          |
|+-----------------------------+------------------------------------------|






On Wed, Jan 23, 2008 at 12:50:24PM +0000, Andrew Bridgeman corusgroup com
wrote:
> I have also just noticed that the following text comes up when i do a
free
> -m. Does this mean i have no dedicated swap space on the hard disk with
the
> OS on it. If this is the case can i add some dynamically with out messing
> up the operating system, as i have 2 gig free on the OS disk currently?
>
>              total       used       free     shared    buffers     cached
> Mem:          2006         94       1912          0          7         43
> -/+ buffers/cache:         43       1963
> Swap:            0          0          0
>
> Any advice would be great.
>

Yeah, looks like you have no swap. :-)  Or at least nothing enabled.

Also, here are settings we use for 32-bit VMware servers which although
had plenty of RAM (24GB), were exhibiting OOM errors:

vm.min_free_kbytes = 16384
vm.overcommit_memory = 2
vm.overcommit_ratio = 75
vm.lower_zone_protection = 80
vm.swappiness = 60

Using these settings, our OOM problems have gone away.

Ray

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list


**********************************************************************
This transmission is confidential and must not be used or disclosed by
anyone other than the intended recipient. Neither Corus Group Limited nor
any of its subsidiaries can accept any responsibility for any use or
misuse of the transmission by anyone.

For address and company registration details of certain entities
within the Corus group of companies, please visit
http://www.corusgroup.com/entities

**********************************************************************




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]