VMware install *arg!*

mark m.roth2006 at rcn.com
Thu Jan 1 23:47:49 UTC 2009

Joshua Gimer wrote:
> And you are sure that it is not already on the system somewhere? What about:
> find / -name version.h
I'm sorry, you misunderstood me. I did make ... version.h, and version.h was
created. HOWEVER, apparently after kernel 2.6.18, they moved the UTS_RELEASE to
its own file, utsrelease.h

I just tried to make it, and it wants me to go through the *whole* kernel
config. I've tried creating a plain file by that name, whose contents are

>> #define UTS_RELEASE <mykernel#>

But it doesn't seem to like that.

> or
> locate version.h
> Josh
> On Thu, Jan 1, 2009 at 4:19 PM, mark <m.roth2006 at rcn.com> wrote:
>> Joshua Gimer wrote:
>>> Try:
>>> yum install kernel-devel
>>> vmware-config
>> Ok, let me, in the interest of full disclosure, say that my workstation is
>> running openSuSE. The idea on installing vmware was a) to get some knowledge of
>> it, and b) to look at going up to CentOS 5.
>> Anyway, with much googling, and suggestions from one or two folks, this is what
>> I've done so far:
>> installed kernel-source (openSuSE doesn't have a separate kernel-headers).
>> I had to do a make .../version.h
>> Then I tried editing it, to add
>> #define UTS_RELEASE <kernel#>
>> Then I read vmware-config.pl, and see that if it's a kernel > 2.6.18, which
>> mine is, it's looking for utsrelease.h
>> Fine. I created that, and it *still* doesn't like it. At this point, I'm doing
>> something I hate, which is debugging code that supposed to be perfect from a
>> package; in this case vmware-config.pl. I'm working on a test.pl that will
>> *tell* me what it is looking at, and what it finds, so I can see *why* it
>> doesn't like it.
>>        mark "I've had fun. This isn't it."
>> --
>> redhat-list mailing list
>> unsubscribe mailto:redhat-list-request at redhat.com?subject=unsubscribe
>> https://www.redhat.com/mailman/listinfo/redhat-list

More information about the redhat-list mailing list