VMware install *arg!* - solved!

mark m.roth2006 at rcn.com
Fri Jan 2 21:32:25 UTC 2009

Joshua Gimer wrote:
> On Thu, Jan 1, 2009 at 2:26 PM, mark <m.roth2006 at rcn.com> wrote:
>> So I'm trying to install. The install script is fine. Then it gets to the point
>> where it offers to run vmware-config. Fine. It wants kernel headers. I wind up
>> having to install the entire kernel source.
>> And VMware complains it can't find version.h, and tells me that I might want to
>> recompile my kernel.
>> I DO NOT WANT TO COMPILE MY FRIGGIN" KERNEL. Anyone know if there's *any* way
>> around this?
> How are you installing the kernel sources? What is the output of 'rpm
> -qa | grep -i kernel' ?

I posted to the VMware server "community", and after a couple of go-rounds, got
the answer: in the linux source tree, I had to do a make cloneconfig, and that
created all the other files I needed, no kernel rebuild necessary.

Still not sure if the utsrelease.h that I manually created was also necessary,
but it was there....

Thanks, all.


More information about the redhat-list mailing list