[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: yum issues with RedHat 5 servers



As a long time RedHat user and customer, honestly this is one of the lamest
issues I've seen with a RedHat ES/AS distribution, in so much is that it
seems to be related directly with rhn and that this prevents us essentially
from routinely being able to schedule patches to our servers and to install
software to the servers on the fly (I wonder how much flack Mirosoft would
take if they had this sort of issue with Windows Update).  I don't mean to
bash the distribution here (I'm actually moving our organization to RedHat
from a predominately Solaris environment), however having done some googling
around, this is an issue that has existed since RedHat 5 was in beta....

I was able to update one of the servers I'm having trouble with, only to
turn around literally 2 minutes later to run yum check-update on the exact
same box, and to run into the exact error again...

Aaron

-----Original Message-----
From: redhat-list-bounces redhat com [mailto:redhat-list-bounces redhat com]
On Behalf Of George Magklaras
Sent: Thursday, January 15, 2009 10:38 AM
To: General Red Hat Linux discussion list
Subject: Re: yum issues with RedHat 5 servers

I confirm that we face the same problem with various servers and we 
attribute this to RHN capacity issues. We had some luck if we delete the 
/var/spool/up2date/loginAuth.pkl in some of our boxes. For others we 
have not managed.

Does anyone know if there is a redhat bugzilla report for this? This 
might raise the status of the issue. If I do not find one, I shall raise 
one.

GM

-- 
--
George Magklaras BSc Hons MPhil
RHCE:805008309135525

Senior Computer Systems Engineer/UNIX-Linux Systems Administrator
EMBnet Technical Management Board
The Biotechnology Centre of Oslo,
University of Oslo
http://folk.uio.no/georgios


Aaron Bliss wrote:
> Hi all,
> On a consistent basis, several RedHat 5 servers produce the following
error
> when attempting to update the boxes:
> error was [Errno -1] Metadata file does not match checksum
> 
> Googling this error, I've tried:
> yum clean all
> yum clean metadata
> rm -rf /var/cache/yum/*
> 
> None of those seem to have any lasting effect.  We have several Centos
> servers, none of which have this issue.  This problem is only effecting
> RedHat servers.  Is there any real solution to this problem?  Is there
> anyone actually affiliated with RedHat that can say this issue is being
> addressed?  I've found a post dated back to 2006 speaking of this issue:
>
https://www.redhat.com/archives/rhelv5-beta-list/2006-September/msg00170.htm
> l
> 
> Obviously not being able to consistently patch servers is a serious issue.
> 
> Aaron
> 
> 
> 




-- 
redhat-list mailing list
unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]