[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Can't update RHEL 5 system



You have xen-3.0.3-94.el5_4.3.x86_64, with xen-libs.x86_64 3.0.3-105.el5_5.3

You have two options for fix the problem:

a) Update Xen to 5_5.3
b) Downgrade xen-libs to 5_4.3

The key is use same version for xen core and all it's dependencies.

Keep in mind that if you combine x86_64 with i386 package, you probably will have problems. I suggest you use the x86_64 package if your system support it.

Regards


El 12/08/2010 12:39, madunix escribió:
xen-3.0.3-94.el5_4.3.x86_64 from installed has depsolving problems
   -->  Missing Dependency: xen-libs = 3.0.3-94.el5_4.3 is needed by
package xen-3.0.3-94.el5_4.3.x86_64 (installed)
Error: Missing Dependency: xen-libs = 3.0.3-94.el5_4.3 is needed by
package xen-3.0.3-94.el5_4.3.x86_64 (installed)
  You could try using --skip-broken to work around the problem
  You could try running: package-cleanup --problems
                         package-cleanup --dupes
                         rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[root linux3 ~]# yum list all | grep xen-libs
xen-libs.i386                        3.0.3-94.el5_4.3       installed
xen-libs.x86_64                      3.0.3-105.el5_5.3      installed
xen-libs.i386                        3.0.3-105.el5_5.5      rhel-x86_64-server-5
xen-libs.x86_64                      3.0.3-105.el5_5.5      rhel-x86_64-server-5


How can I proceed...?

Thanks

2010/8/3 "Francisco J. Márquez Gómez"<fjmarquez chguadalquivir es>:
El 29/07/2010 20:24, Paolo Galtieri escribió:
On 07/29/2010 09:06 AM, Josh Miller wrote:
On 07/28/2010 07:52 PM, Paolo Galtieri wrote:
--->  Package xen-libs.i386 0:3.0.3-105.el5_5.4 set to be updated
--->  Package xulrunner.i386 0:1.9.2.7-3.el5 set to be updated
-->  Finished Dependency Resolution
xen-3.0.3-105.el5_5.3.i386 from installed has depsolving problems
-->  Missing Dependency: xen-libs = 3.0.3-105.el5_5.3 is needed by
package xen-3.0.3-105.el5_5.3.i386 (installed)
Error: Missing Dependency: xen-libs = 3.0.3-105.el5_5.3 is needed by
package xen-3.0.3-105.el5_5.3.i386 (installed)
It looks like xen-3.0.3-105.el5_5.4.i386 is not available in your
repository.  Are you hosting your own repositories locally or are you using
a public repository?  Can you verify that xen-3.0.3-105.el5_5.4.i386 is
available from one of your repositories?


I do not host my own repositories.  I'm using the standard RH
repositories.

[root playin ~]# yum list all | grep xen-libs
xen-libs.i386                          3.0.3-105.el5_5.3      installed
xen-libs.i386                          3.0.3-105.el5_5.5
  rhel-i386-server-5

The package is available, and is now version 5.5, but the problem still
exists.  I believe the problem is that the xen package depends on version
5.3 of xen-libs.  So until there is an update to the xen package I'm going
to continue to see this failure.

Paolo
The problem is that you don't have the same "most updated" version for xen
and xen-libs. You appear are updating xen-libs to 5.5.4, but xen 5.5.3
installed in your system require xen-libs 5.5.3.

For fix this situation, you need xen 5.5.4, or xen 5.5.5, since your "yum
list all | grep xen-libs " output show as available the xen-libs 5_5.5
package.

In any case, you need same version for xen and xen-libs.

Regards,
F.J

--

Francisco J. Márquez Gómez
Servicio de Informática (Área de sistemas)
Confederación Hidrográfica del Guadalquivir
Tel.: 954.348.778
fjmarquez chguadalquivir es
www.chguadalquivir.es

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request redhat com?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list


--

Francisco J. Márquez Gómez
Servicio de Informática (Área de sistemas)
Confederación Hidrográfica del Guadalquivir
Tel.: 954.348.778
fjmarquez chguadalquivir es
www.chguadalquivir.es



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]