[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

racoon segmentation fault



I finally got IPSec working between one linux server and 2 windows
servers, but about every 8 hours, I get a 

segmentation fault and racoon goes away.  The error is always:

 

Mar  3 14:20:31 STORE191 racoon: NOTIFY: the packet is retransmitted by
128.xx.xx.xxx[500]. 

Mar  3 14:20:31 STORE191 racoon: WARNING: the packet retransmitted in a
short time from 128.xx.xx.xx[500] 

Mar  3 14:20:31 STORE191 racoon: NOTIFY: the packet is retransmitted by
128.xx.xx.xx[500]. 

Mar  3 14:20:31 STORE191 racoon: ERROR: wrong state 8. 

Mar  3 14:20:31 STORE191 racoon: ERROR: failed to pre-process packet. 

Mar  3 14:20:31 STORE191 racoon: INFO: IPsec-SA established:
ESP/Transport 128.xx.xx.xx[0]->128.yy.yy.yy[0] spi=58532716(0x37d236c) 

Mar  3 14:20:31 STORE191 kernel: racoon[18824]: segfault at
0000000000000018 rip 00000000004068a7 rsp 00007fff8fb715f0 error 4

 

where xx is one of the 2 windows servers, and yy is the linux server.
This is a test setup, so not very heavy traffic right now, but there is
one

NFS mounted drive from the linux server to both windows servers.  Racoon
restarts easily, and I just have to log onto each windows server when

I restart, and ping the linux, to re-establish connection.

 

I have a ping from the linux server to each of the windows server every
5-10 minutes to keep the tunnel alive, otherwise it drops the
connection. 

 

Any ideas would be appreciated.

 

Thanks,

Peter Shulkin



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]