PHP 5.3.3 install conflict

Florez, Nestor NFlorez at
Wed May 18 21:30:19 UTC 2011


I am trying to upgrade my php from version 5.2.14 to version 5.3.3 and I am having a conflict.

Package-cleanup is the yum_utils package but when I do  'yum install yum_utils' I get
After this I ran package-cleanup and it stills complaint when I tried to install php53

Have you ran into this problem?

How did you solve it?

[root at WESC ~]# yum install php53

Loaded plugins: rhnplugin

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package php53.x86_64 0:5.3.3-1.el5_6.1 set to be updated

--> Processing Dependency: php53-common = 5.3.3-1.el5_6.1 for package:

--> php53 Processing Dependency: php53-cli = 5.3.3-1.el5_6.1 for

--> package: php53 Running transaction check

---> Package php53-cli.x86_64 0:5.3.3-1.el5_6.1 set to be updated

---> Package php53-common.x86_64 0:5.3.3-1.el5_6.1 set to be updated

--> Processing Conflict: php53-common conflicts php-common Finished

--> Dependency Resolution

php53-common-5.3.3-1.el5_6.1.x86_64 from rhel-x86_64-server-5 has depsolving problems

  --> php53-common conflicts with php52-common

Error: php53-common conflicts with php52-common  You could try using --skip-broken to work around the problem  You could try running: package-cleanup --problems

             package-cleanup --dupes

             rpm -Va --nofiles --nodigest

The program package-cleanup is found in the yum-utils package.


More information about the redhat-list mailing list