[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHBA-2000:081-05] Update Agent's rhnsd daemon leaks file descriptors



---------------------------------------------------------------------
                   Red Hat, Inc. Bug Fix Advisory

Synopsis:          Update Agent's rhnsd daemon leaks file descriptors
Advisory ID:       RHBA-2000:081-05
Issue date:        2000-10-06
Updated on:        2000-10-09
Product:           Red Hat Linux
Keywords:          rhnsd up2date leak file descriptors
Cross references:  N/A
---------------------------------------------------------------------

1. Topic:

The new Update Agent provided with Red Hat Linux 7.0 contains a daemon to
connect to Red Hat Network.  This program leaks file descriptors, causing
all descriptors to be used up after approximately three weeks time.

2. Relevant releases/architectures:

Red Hat Linux 7.0 - i386
Red Hat Linux 7.0J - i386

3. Problem description:

The new Update Agent provided with Red Hat Linux 7.0 contains a daemon,
rhnsd, which periodically polls Red Hat Network for updates.  This daemon
leaks file descriptors.  On a default installation, all available file
descriptors will be used by rhnsd in approximately three weeks, making the
system unusable.

4. Solution:

If you do not use Red Hat Network and do not want your machine to
automatically poll for updates, you can turn off the rhnsd daemon using the
following commands (while logged in as root):

        /sbin/service rhnsd stop
        /sinb/chkconfig --level 345 rhnsd off

If you have subscribed your machine on the Red Hat Network, you will need
to update the up2date packages listed in this errata advisory. You can use
the Red Hat Update Agent to upgrade your machine by executing it from a
command shell:

        up2date

If you want to download the new packages and manually upgrade your system,
run the following command for each RPM for your particular architecture:

	rpm -Fvh [filename]

where [filename] is the name of the RPM.

5. Bug IDs fixed (http://bugzilla.redhat.com/bugzilla for more info):

15365 - Swedish up2date .desktop file translation
17931 - unclear $INTERVAL comment in rhsnd init script
17933 - Bogus syslog messages from rhn_check
17934 - rhnsd should not run by default
18345 - rhnds leaking file descriptors
18543 - --anonymous command line options don't work


6. RPMs required:

Red Hat Linux 7.0:

i386:
ftp://updates.redhat.com/7.0/i386/up2date-2.0.6-1.i386.rpm
ftp://updates.redhat.com/7.0/i386/up2date-gnome-2.0.6-1.i386.rpm

sources:
ftp://updates.redhat.com/7.0/SRPMS/up2date-2.0.6-1.src.rpm

7. Verification:

MD5 sum                           Package Name
--------------------------------------------------------------------------
b8303934911a01264827cf31843f4b6b  7.0/SRPMS/up2date-2.0.6-1.src.rpm
3ad4e98a1ed5ba2974c195387dad8236  7.0/i386/up2date-2.0.6-1.i386.rpm
695c50d2101e6106d05cb6c99e12e187  7.0/i386/up2date-gnome-2.0.6-1.i386.rpm

These packages are GPG signed by Red Hat, Inc. for security.  Our key
is available at:
    http://www.redhat.com/corp/contact.html

You can verify each package with the following command:
    rpm --checksig  <filename>

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the md5sum with the following command:
    rpm --checksig --nogpg <filename>

8. References:

N/A


Copyright(c) 2000 Red Hat, Inc.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]