[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[rhelv6-list] Fwd: Redhat 6 installation failures common [SOLVED]




I've redone the installation a few times to verify and gather data/errors.

Redhat 5 installs OK.  Completely updated to 5.6 and rebooted fine.
Debian 6 installs OK.  Boots fine.

Redhat 6 CDROM netinstaller does not see CDROM drive as possible media
source, after having booted from it.

Redhat 6 DVD installer has an anaconda error when we select either replacing
the partitions or custom.  Prior to selecting one of those options the installer
produced this warning:

Warning

disks sda,sdb contains BIOS RAID metadata but are not part of any recognized
BIOS RAIDsets.  Ignoring disks sda, sdb.

In one case the existing RAID had been created by RH5, and in another case
of this install trial history, it had a RAID created by Debian 6.

We can say OK to the warning, and try the default option to reuse and reformat
the existing Linux partition, or chose the custom layout.  Either way, there
is an anaconda exception:

anaconda 13.21.82 exception report
Traceback (most recent call first)
File "/usr/lib/anaconda/iw/cleardisks_gui.py", line 154, in getScreen
selfbootDisk = sorted(names, self.anaconda.id.storage.compareDisks)[0]
...
IndexError: list index out of range

Eventually we noticed another error on another screen about
RAID blocks and it refered to a driver device starting with sil_
My colleague recalled the drives had been taken from a SATA
storage bay which had been used with a Silicon Image controller
in the past.  It seemed unlikely RAID blocks could be present
from that long ago, as we had these disks working as a Debian or
Redhat 5 with software RAID 1.

I used dd to wipe the first part of the drives with zeros and attempted the
installation of RH6 from DVD again.  Still saw the RAID metadata error.
I wiped up to the first 5 GB of the disks, and no difference.

Then I left dd running at the end of the day to write zeros right
to the end of the drives.  (WARNING: the following command wipes all data
from disks, including partition tables...)

# dd if=/dev/zero of=/dev/sda bs=8192
# dd if=/dev/zero of=/dev/sdb bs=8192

This morning I tried an install and no more errors about the
BIOS RAID metadata.  The RH 6 install completed and it boots fine
as MD RAID 1.

There are two flaws in the Redhat installer compared to RH 5 installer.
The CDROM installation has problems seeing the very media it booted from,
and the scan of the disk for existing RAID metadata has no way of saying
lets force use of these disks despite finding some relic of RAID metadata on them.
Debian 6 nor Redhat Enterprise 5 had problems reusing the disks while there was still
some prior hint of RAID metadata.

--Donald



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]