[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rhelv6-list] kickstarting rhel6 from usb key

On 6/15/11 3:44 PM, Jason Keltz wrote:
> Hi.
> I'm kickstarting a new Red Hat 6.0 system from a USB key.
> I've kickstarted it many times from the key in the last week, and the
> USB key is recognized as sdb, and the system hard disk as sda.
> However, this morning, I went to kickstart, and the USB key was suddenly
> being recognized as sda which, of course messed up the process.
> I tried it various times, and it continued to be that way.
> I then had to leave it for a while because I was busy with other stuff.
> When I came back, the hard disk is now being recognized as sda, usb key
> as sdb.
> What's up?  seems like an odd bug...

Have you tried the RHEL 6.1 boot on your USB key to see if they fixed
any kernel/udev/Anaconda ordering issues?  I know a lot of work has gone
into the various pieces to make sure the BIOS boot device (your RAID
controller) is sda.  Are you sure your RAID controller was ready each
time you booted from USB?  Maybe the times USB was seen as sda were the
times RAID was not fully ready and so it was detected second?

I'm grasping at straws since I'm used to any USB boot devices being
enumerated after the locally attached SCSI/SAS storage.  Are you running
the latest BIOS on your server platform?

       Brian Long                             |       |
       Corporate Security Programs Org    . | | | . | | | .
                                              '       '
                                              C I S C O

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]