[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RFE: Use generic names in packages

On Sun, 1 Jul 2007, Paul W. Frields wrote:

On Sun, 2007-07-01 at 10:42 -0400, Jesse Keating wrote:
On Saturday 30 June 2007 19:04:18 Rahul Sundaram wrote:
EPEL isn't targeted for Fedora. I did refer to the discussion. Think
about this from the end user perspective rather than from the project

"Fedora" is more than a distribution.

Two suggestions:

1.  Short required blurb at the top of all README.Fedora such as:
   "This documentation file is provided by the Fedora Project, from
which this package is derived for use by a number of distributions.  For
more information about this derivation, refer to <LINK>."

2.  Making use of the $DISTVAR in Makefile.common:

--- Makefile.common.original    2007-07-01 16:43:18.000000000 -0400
+++ Makefile.common     2007-07-01 16:44:00.000000000 -0400
@@ -25,7 +25,7 @@
DIST = $(word 2, $(BRANCHINFO))
DISTVAR = $(word 3, $(BRANCHINFO))
DISTVAL = $(word 4, $(BRANCHINFO))
-DIST_DEFINES = --define "dist $(DIST)" --define "$(DISTVAR) $(DISTVAL)"
+DIST_DEFINES = --define "dist $(DIST)" --define "distvar $(DISTVAR)"
--define "$(DISTVAR) $(DISTVAL)"

BUILD_FLAGS ?=  $(shell echo $(KOJI_FLAGS))

Then simply use README.%{distvar} in the spec.  My personal preference
is alternative #1 because like others I see value in spreading the
Fedora brand name.  If someone's already looking through README files
it's hard to make a case that they'll turn up their noses at
README.Fedora, simply because of the name, in the absence of any other
docs covering their needs.

2) is one solution to "which repository this package came from" type of question, but if/when the package behaves exactly the same whether it's on RHEL (from EPEL) or Fedora, why should the name change? It's not distro-specific but packaging specific information so README.epel vs README.somethingelse is just wrong in that case. README.packaging (not distribution) or similar would be to the point.

1) is a good option, it just means defining the README.something to mean README.<vendor>, not README.<distribution> whereas it currently means
vaguely both or either.

	- Panu -

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]