[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: AucTeX dependencies and TeXLive 2009



On Mon, 2009-08-31 at 13:01 +0200, Jindrich Novy wrote:
> On Sun, Aug 30, 2009 at 07:23:50PM -0400, Matthew Saltzman wrote:
> > Here's what happens when I try to install AucTeX for Emacs with texlive-2009:
> > 
> >         $ sudo yum install emacs-auctex
> >         Loaded plugins: refresh-packagekit
> >         Excluding Packages from RPM Fusion for Fedora 11 - Nonfree
> >         Finished
> >         Excluding Packages from RPM Fusion for Fedora 11 - Nonfree - Updates
> >         Finished
> >         Excluding Packages from Fedora 11 - x86_64 - Updates
> >         Finished
> >         Setting up Install Process
> >         Resolving Dependencies
> >         --> Running transaction check
> >         ---> Package emacs-auctex.noarch 0:11.85-8.fc11 set to be updated
> >         --> Processing Dependency: tex-preview = 11.85-8.fc11 for package: emacs-auctex-11.85-8.fc11.noarch
> >         --> Processing Dependency: dvipng for package: emacs-auctex-11.85-8.fc11.noarch
> >         --> Running transaction check
> >         ---> Package dvipng.x86_64 0:1.11-2.fc11 set to be updated
> >         --> Processing Dependency: libkpathsea.so.4()(64bit) for package: dvipng-1.11-2.fc11.x86_64
> >         ---> Package tex-preview.noarch 0:11.85-8.fc11 set to be updated
> >         --> Running transaction check
> >         ---> Package kpathsea.x86_64 0:2007-42.fc11 set to be updated
> >         --> Processing Dependency: texlive = 2007-42.fc11 for package: kpathsea-2007-42.fc11.x86_64
> >         --> Finished Dependency Resolution
> >         kpathsea-2007-42.fc11.x86_64 from fedora has depsolving problems
> >           --> Missing Dependency: texlive = 2007-42.fc11 is needed by package kpathsea-2007-42.fc11.x86_64 (fedora)
> >         Error: Missing Dependency: texlive = 2007-42.fc11 is needed by package kpathsea-2007-42.fc11.x86_64 (fedora)
> >          You could try using --skip-broken to work around the problem
> >          You could try running: package-cleanup --problems
> >                                 package-cleanup --dupes
> >                                 rpm -Va --nofiles --nodigest
> > 
> > I have texlive-dvipng, texlive-kpathsea, and texlive-preview installed.
> > Should I file a bug someplace?
> 
> Hmmm, it looks like a problem in how yum resolves obsoletes/provides.
> I will get exactly this when I try to install emacs-auctex, but if I
> do:
> 
> yum install dvipng -y
> 
> then texlive-dvipng and texlive-dvipng-bin get successfully installed.
> 
> Then installation of emacs-auctex runs without problems. So it seems
> like yum has a hard time to resolve both installation of emacs-auctex and
> obsoletion of dvipng in one transaction even though emacs-auctex
> contains unversioned Requires: to dvipng and texlive-dvipng should
> successfully obsolete it.

I'm not seeing the "install without problems" behavior, unfortunately.
The messages above come from after installing texlive-dvipng*.  After
latest updates:

        [mjs yankee ~]$ sudo yum install emacs-auctex
        Loaded plugins: refresh-packagekit
        Excluding Packages from RPM Fusion for Fedora 11 - Nonfree
        Finished
        Excluding Packages from RPM Fusion for Fedora 11 - Nonfree - Updates
        Finished
        Excluding Packages from Fedora 11 - x86_64 - Updates
        Finished
        Setting up Install Process
        Resolving Dependencies
        --> Running transaction check
        ---> Package emacs-auctex.noarch 0:11.85-8.fc11 set to be updated
        --> Processing Dependency: tex-preview = 11.85-8.fc11 for package: emacs-auctex-11.85-8.fc11.noarch
        --> Processing Dependency: dvipng for package: emacs-auctex-11.85-8.fc11.noarch
        --> Running transaction check
        ---> Package dvipng.x86_64 0:1.11-2.fc11 set to be updated
        --> Processing Dependency: libkpathsea.so.4()(64bit) for package: dvipng-1.11-2.fc11.x86_64
        ---> Package tex-preview.noarch 0:11.85-8.fc11 set to be updated
        --> Running transaction check
        ---> Package kpathsea.x86_64 0:2007-42.fc11 set to be updated
        --> Processing Dependency: texlive = 2007-42.fc11 for package: kpathsea-2007-42.fc11.x86_64
        --> Finished Dependency Resolution
        kpathsea-2007-42.fc11.x86_64 from fedora has depsolving problems
          --> Missing Dependency: texlive = 2007-42.fc11 is needed by package kpathsea-2007-42.fc11.x86_64 (fedora)
        Error: Missing Dependency: texlive = 2007-42.fc11 is needed by package kpathsea-2007-42.fc11.x86_64 (fedora)
         You could try using --skip-broken to work around the problem
         You could try running: package-cleanup --problems
                                package-cleanup --dupes
                                rpm -Va --nofiles --nodigest
        [mjs yankee ~]$ rpm -qa \*dvipng\*
        texlive-dvipng-2009-1.12.13822.fc11.noarch
        texlive-dvipng-bin-2009-14697.fc11.x86_64
        [mjs yankee ~]$ rpm -qa \*kpathsea\*
        texlive-kpathsea-2009-14773.fc11.noarch
        texlive-kpathsea-lib-2009-0.3.20090828.fc11.x86_64
        texlive-kpathsea-lib-2009-0.3.20090828.fc11.i586
        texlive-kpathsea-bin-2009-14403.fc11.x86_64
        
-- 
                Matthew Saltzman

Clemson University Math Sciences
mjs AT clemson DOT edu
http://www.math.clemson.edu/~mjs


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]