[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: AucTeX dependencies and TeXLive 2009



2009/8/31 Thomas Moschny <thomas moschny gmail com>:
> 2009/8/31 Jindrich Novy <jnovy redhat com>:
>> Then installation of emacs-auctex runs without problems. So it seems
>> like yum has a hard time to resolve both installation of emacs-auctex and
>> obsoletion of dvipng in one transaction even though emacs-auctex
>> contains unversioned Requires: to dvipng and texlive-dvipng should
>> successfully obsolete it.
>
> But doing installation that way, I end up with both installed:
>
> tex-preview-11.85-8.fc11.noarch
> texlive-preview-2009-11.84.13530.fc11.noarch
>
> Is that intentional? Seems emacs-auctex requires 11.85, while your
> package provides 11.84.

AucTeX is the upstream for the preview tex package - so this is
another case where we need to decide whether to go with upstream or
the texlive version.

In this case, I think we have to go with the upstream (AucTeX) one as
each Auctex release is tested against the bundled preview class.

Jonathan (emacs-auctex maintainer).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]