[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Test-Announce] Graphics Test Week (ATI, NVIDIA and Intel graphics Test Days)



On 09/10/2009 09:10 AM, Adam Williamson wrote:
On Thu, 2009-09-10 at 08:49 -0600, Dariusz J. Garbowski wrote:
On 09/08/2009 03:26 PM, Adam Williamson wrote:
Yes, it is now that legendary time, well loved by the hearts of men for
millennia(*): Graphics Test Week!

Tomorrow - 2009-09-09 - is ATI/AMD Radeon graphics card Test Day (1).
Using 2009-09-09 ISO, when passing 'radeon.modeset=1' as boot param, I get "Unknown boot option 'radeon.modeset=1'. Ignoring..."
Is that expected?

(sending to all lists as this is #1 Top Question...)

Yes, it is. The 'science bit' is that the kernel itself truly doesn't
understand the parameter, which is why you see this message - but the
radeon. prefix means it gets automatically passed on to the radeon
module, which _does_ understand (and interprets) it.

Personally I consider this a kernel bug, it shouldn't display this
message for parameters which will be passed to modules.

Thanks to all who responded with explanation. This indeed is confusing and I agree with you that this deserves a "bug" status...

radeon.modeset=1 is a no-op, though, modesetting is now default for
Radeon chips. So only radeon.modeset=0 (to disable it) makes any sense.
Did I leave radeon.modeset=1 in one of the test cases?
Errr... I thought I saw it there yesterday but I might be wrong (I have taken a not of this the day before). I can't see it anywhere today.

BTW: my test report on wiki.

--
thufor






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]