[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Troubles running F9 mock chroot under F11


A number of difficulties/unfortunate circumstances are combining and
causing me a headache. I'm looking for help/ideas on getting around

I am trying to build a customized version of the OLPC XS school server
for the OLPC deployment here in Nepal. The latest XS release is based
on F9. An F11/F12 update is on the cards, but the XS development team
is small and has more pressing priorities right now.

The internet connection here at the office is too slow to make local
builds, and also the power get turned off every night.

We do have a F11 box at the ISP which has a satisfactory internet
connection and reliable power, and we do have a speedy connection from
the office to that box. This box is also used to build other software
components for the deployment so there are multiple reasons why it
makes sense for us to run the school server build there.

The XS build system uses revisor and the upstream version is built on
a F9 box. My problems originate from having to build our customized
version from F11. We do not have the hardware or space to install a F9
box there, and we cannot downgrade our F11 system.

The first thing I tried is to use the F11 revisor to build the F9 XS
release. No luck - it fails on anaconda buildinstall due to big
differences in the F11 anaconda on the host system vs the F9 anaconda
in the target media. Not too surprising.

I looked into using pungi instead, but the documentation states:
"Pungi needs to run on the arch it is composing, as root, and with an
install of what it is composing, eg if you are composing Fedora 8, you
need to be running Fedora 8."

I then tried to create a F9 chroot using mock, with the intention of
running revisor or pungi inside. This doesn't work, because mock
creates a v9 berkeley DB inside the chroot, but the libraries/apps
inside the chroot only support bdb v8. So running "rpm -qa" inside a
fresh F9 chroot on F11 gives you these errors:
    mock-chroot> rpm -qa
    rpmdb: /var/lib/rpm/Packages: unsupported hash version: 9
    error: cannot open Packages index using db3 - Invalid argument (22)
    error: cannot open Packages database in /var/lib/rpm
And revisor and pungi fail in the same way, even  though the Pungi
docs suggest this kind of thing should be possible:

Finally I tried to use db_dump on the F11 host to dump the database
using the v9 tools, to go into the chroot and use db_load to import it
using the v8 tools, but this also results in a v9 database being
loaded :(

Any further ideas or suggestions?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]