[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mplayer problems

Gene Heskett wrote:
Ian Malone wrote:
Gene Heskett wrote:
A day or so back i hit a web site that needed mplayer, which went thru the motions of downloading the file, but when it tried to play it, stopped immediately, several times.

Today I thought I'd see if yumex could help and told it to install a few more skins and other mplayer accessories.

It starts process the queue, and fails because it can't find mplayer, but if I goto the removal screen, mplayer shows as installed and I can't uninstall it because of all the other dependencies.

rpm says this version is installed:
[root diablo ~]# rpm -q mplayer
but yumex reports this
Missing Dependency: mplayer = 1.0-0.39.20060412.lvn5 is needed by package mplayer-gui
So obviously thats a livna item, but its not shown as being available.

Which magic twanger do I need folks?

At a guess you've installed from incompatible repos, I think the
Livna packages are not, in general, compatible with freshrpms,
atrpms et al (mplayer-1.0pre8-0.6.20060406 sounds like atrpms
or freshrpms).  So either rpm -e mplayer, or use yum's
--disablerepo switch to ignore livna and install mplayer-gui from
the same repo as mplayer.

There are not, nor has there been, any freshrpms or atrpms even listed in the repo lists. The only oddball is crash-hat. I'll try disabling livna though, just for effects. Thanks.

Based on that, I tried this since yum was complaining about the mplayer installed being newer than the lvn5 version:
First I dl'd the livna version with FF, saving it locally, then:
[root diablo src]# rpm -Uvh --oldpackage mplayer-1.0-0.39.20060412.lvn5.i386.rpm
error: Failed dependencies:
        libdvdread.so.3 is needed by mplayer-1.0-0.39.20060412.lvn5.i386
        libenca.so.0 is needed by mplayer-1.0-0.39.20060412.lvn5.i386
liblirc_client.so.0 is needed by mplayer-1.0-0.39.20060412.lvn5.i386
        liblzo.so.1 is needed by mplayer-1.0-0.39.20060412.lvn5.i386
        libopenal.so.0 is needed by mplayer-1.0-0.39.20060412.lvn5.i386
mplayer-fonts >= 1.1-0.lvn.2 is needed by mplayer-1.0-0.39.20060412.lvn5.i386

So I'm well on the way to dependency hell, and mplayer isn't working.

I've NDI where the installed mplayer that doesn't work came from, and short of an FC5 reinstall, apparently no way to fix it. But all trails will be checked as suggested by folks here.

yum.log.1 shows:
Apr 22 04:54:34 Installed: mplayer.i386 5:1.0pre8-0.6.20060406
Apr 22 04:54:35 Installed: mplayerplug-in.i386 3.21-1.lvn5
Apr 23 18:31:28 Updated: mplayerplug-in.i386 3.25-1.lvn5

Now, I think yumex and its automatic dependency stuff could probably resolve this IF I could get it to show me the mplayer.x.lvn5 as being available, but I cannot because it thinks the installed one is newer.
So I'm apparently damned if i do, and damned if i don't.

Cheers, Gene

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]