[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem booting from PXE/kickstart on FC7

Gary Schlachter wrote:

Mike Wright wrote:

Gary Schlachter wrote:

Mike Wright wrote:

Gary Schlachter wrote:

I am trying to use PXE/kickstart to load FC7 on an appliance. My initrd.img and vmlinuz are from FC7 and are loading but my console output looks like the following:

<big snip />

Switching to new root and running init.
umounting old /dev
umounting old /proc
umounting old /sys
switchroot: mount failed: No such file or directory
Booting has failed.
Kernel panic - not syncing:  Attempted to kill init!

Any and all thoughts would be greatly appreciated!

Hi Gary,

I'll take a stab at it.

I nfs install f7 using pxeboot and kickstart. I seem to remember struggling with something similar. It turned out that in the pxeboot stanza I had broken the APPEND line using "\". Big no-no. The "\" is for readability. The APPEND line and all its options must be on a single line. Once I'd done that it worked correctly.

If that doesn't solve the problem would you post your pxeboot stanza? Might be a clue there.

Mike Wright :m)

I finally got my initrd.img to load. I found a post about changing the init script in the initrd.img from

   mount /sysroot


   mount -o defaults --ro -t ext3 /dev/VolGroup00/LogVol00 /sysroot

and that did the trick. However now my kickstart file is not being used. My pxelinux.xfg/default looks like

      label linux
      kernel vmlinuz
append initrd=initrd.fc7.img ks=nfs: ramdisk_size=9216

I have tried with and without the ksdevice=eth0 on the "append" line as well. It is like the "ks=" is being ignored by the kernel alotugh I can see it as a kernel option on the console.

Hmmm, couple possibilities:

Is the nfs server running and has the kickstart file been exported? Is that machine running iptables and are the required nfs ports open?

When I was trying to debug my setup tcpdump was definitely my best friend.

Yes to all since I am able to boot other systems with FC1 from the same setup. My PXE prompt has multiple options one of which is Fedora Core 1 and another is Fedora Core 7.

Our APPEND lines are very different.  Here's mine:

APPEND ksdevice=eth0 load_ramdisk=1 initrd=images/fc7-install.img network ks=nfs:lan51:/opt/fc7/ks.cfg

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]