[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: VMWare on Fedora 8

Christopher A. Williams wrote:
On Mon, 2007-11-19 at 10:00 -0500, Greg Sieranski wrote:
Tom London wrote:
I've had VMWare 6.02 running on Rawhide on X86 for quite a while.

Requires a patch to /usr/lib/vmware/net-services.sh to fix a bug it
has with SELinux that makes it ask to rerun 'vmware-config.pl' each

--- net-services.sh.old 2007-10-01 14:45:51.000000000 -0700
+++ net-services.sh     2007-10-12 10:41:19.000000000 -0700
@@ -258,7 +258,7 @@

 # Determine if SELinux is enabled
 isSELinuxEnabled() {
-   if [ "`cat /selinux/enforce 2> /dev/null`" = "1" ]; then
+   if [ -x /usr/sbin/selinuxenabled ] && /usr/sbin/selinuxenabled ; then
       echo "yes"
       echo "no"
@@ -616,6 +616,9 @@
    if [ ! -e "$vDevice" ]; then
       mknod -m 600 "$vDevice" c 119 "$vHubNr"
+   if [ "`isSELinuxEnabled`" = 'yes' ]; then
+      restorecon "$vDevice"
+   fi

 # Create a virtual host ethernet interface and connect it to a virtual

Haven't tested/tried on x64....

am running Fedora 8( with VMWare workstation 6.0.2(build-59824) on a T60p.

I found that Vmware would start up fine but if I tried to open an image file I would recieve:

(vmware-tray:15135): Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)
/usr/lib/vmware/bin/vmware: symbol lookup error:
/usr/lib64/gtk-2.0/2.10.0/filesystems/libgnome-vfs.so: undefined
symbol: g_get_user_special_dir

The work around was to set VMWARE_USE_SHIPPED_GTK=no. This allowed me to open up images I had previously created. Now when I tried to start up the images I would get the "Version mismatch with vmmon module: expecting 167.0, got 161.0". So I tried reinstalling vmware and not running the any-any-update114 patch. Now, I do not get the version mismatch error but my system just locks up and I have to hold down the power button to reboot.

I tried downgrading to VMWare Workstation 6.0.0 and applying the any-any-update114 but my system still locks up.

Two things:

1) I'm running F8 x86_64 on a HP8510w laptop with Workstation 6.0.2 and
can vouch that the above patch works perfectly!

2) In my experience, vmware-any-any114 does much more harm than good on
Workstation 6.0.X - although it is a must if you're running VMware
Server. I would start over and totally remove ALL vestiges of VMware
from your system, then re-install 6.0.2. After that, use the patch
supplied above. VMware would hard freeze my system without the patch
because the vmnet nodes were gone and it apparently caused a cascading
set of other issues.

I also got the gtk error, but ignored it after using the patch and all
seems functional.

Hope that helps!



In theory there is no difference between theory and practice.
In practice there is.

--Yogi Berra

I'm reinstalling VMWare and going to try the patch you suggested. I removed VMWare using rpm -erase. Do you think I need to also remove the .vmware dir in my home directory. It just contains the license key and some preferences so Im not sure if it would hurt anything to leave it.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]