[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Migration Of All Users In LDAP Server In LINUX Fedora!

Dear All Openldap USERS on Fedora-Linux,

This is Jyotishmaan Ray, from Silchar, India.

I have been working on migration of users from fedora-linux server to LDAP server. Of late after i have migrated the all users, as per the adminitration guide of openldap sofware, i realised that i have done something wrong, because of which the authentication is not successfully happening.

Now please those openldap experts who are on linux-fedora platform please kindly pay attention to my questions:-

1) Is it necessary to execute the following steps :-

Now you are ready to migrate the data (actually it works even without the export command):

export ETC_SHADOW=/etc/shadow
./migrate_base.pl > /tmp/base.ldif
./migrate_group.pl /etc/group /tmp/group.ldif
./migrate_hosts.pl /etc/hosts /tmp/hosts.ldif
./migrate_passwd.pl /etc/passwd /tmp/passwd.ldif

Now we have the data in the format understood by LDAP server. Please open one the files with text editor to get used to the syntax. After that we can add the data from ldifs.

ldapadd -D "cn=Manager,dc=domain,dc=com" -W -f /tmp/base.ldif

ldapadd -D "cn=Manager,dc=domain,dc=com" -W -f /tmp/group.ldif

ldapadd -D "cn=Manager,dc=domain,dc=com" -W -f /tmp/passwd.ldif

ldapadd -D "cn=Manager,dc=domain,dc=com" -W -f /tmp/hosts.ldif

However, i have not performed all the above steps except for the addition of users!!

As of now, when i finger the users, it shows fine. But when i try to log ion to the server machine using ssh localhost.localdomain. -l xyx,

it asks me the password twice one trial after another and susequently throwing the message:-

[root authdns bin]# ssh authdns.nits.ac.in -l jmaan
jmaan authdns nits ac in's password:
Permission denied, please try again.
jmaan authdns nits ac in's password:
Permission denied, please try again.
jmaan authdns nits ac in's password:
Permission denied (publickey,gssapi-with-mic,password).

[root authdns bin]#

After seaching on the google.co.in, i have changed the default permission of the /dev/tty (666) to 777.

Still it is not successfully working with ssh. I just wanted to make it sure that i could log in with user locally, to my server. However, the /etc/passwd file does not shows the passwd field of the users as 'x' but rather as '*'.

To check this i have tried using the command,

getent passwd|grep user

it worked fine.

Please tell me it is because i have not performed the first few steps of ldapadd of base.ldif, hosts.ldif, group.ldif to the ldap server that, its not working.

I have also worked with the command:-


to generate the new shadow file from  the /etc/passwd file.

Please help!!
With Thanks and Regards,
Jyotishmaan Ray
Moderator Of Paradise Groups
Are You Spiritually Aware  !!! Are You Enjoying Yourself  !!!  See What All You Had Been Missing !!!!
Please Join Immediately By Sending A Blank Mail @ 
Spirituality-Paradise-subscribe yahoogroups com

Be a better sports nut! Let your teams follow you with Yahoo Mobile. Try it now.
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]