[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[scl.org] Question about generating RPMs that depend on SCLs (like python27)



Hi,

I'm creating an RPM (and spec file) that needs Python 2.7 (the python27 scl). When I generate it for RHEL6/CentOS6, I the RPM I create has some automatically generated dependencies which python27 does not seem to fulfill...


Error: Package: assimilation-cma-0.1.4-0.30.x86_64 (/assimilation-cma-0.1.4-0.30.x86_64)
           Requires: python(abi) = 2.7
           Installed: python-2.6.6-52.el6.x86_64 (@Updates/$releasever)
               python(abi) = 2.6
           Available: python-2.6.6-51.el6.x86_64 (base)
               python(abi) = 2.6

The spec file knows if it needs python27 or not.


What do I do in my spec file to make this problem go away?


--
    Alan Robertson <alanr unix sh> - @OSSAlanR

"Openness is the foundation and preservative of friendship...  Let me claim from you at all times your undisguised opinions." - William Wilberforce


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]