[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [scl.org] Disabling debuginfo package generation



On 6. 5. 2015 at 13:16:28, Paul Oehler wrote:
> Hello,
> 
> I'm trying to bundle a scl version of the ioncube php loader, but the
> rpm build process fails saying:
> 
> + /usr/lib/rpm/find-debuginfo.sh --strict-build-id
> /builddir/build/BUILD/php54iw-php-ioncube-loader-5.0.3
> extracting debug info from
> /builddir/build/BUILDROOT/php54iw-php-ioncube-loader-5.0.3-4.iworx.el6.i386/
> opt/iworx/php54iw/root/usr/lib/php/modules/ioncube_loader_lin_5.4.so ***
> ERROR: No build ID note found in
> /builddir/build/BUILDROOT/php54iw-php-ioncube-loader-5.0.3-4.iworx.el6.i386/
> opt/iworx/php54iw/root/usr/lib/php/modules/ioncube_loader_lin_5.4.so
> 
> I've tried multiple variations of disabling the debug_package in the
> spec file, including:
> %define debug_package %{nil}
> %global debug_package %{nil}
> and placing those in various places in the spec.
> 
> I've also tried passing a define to mock to disable debug_package, but
> to no avail.  It seems like when building a package with scl, it is
> determined to try to generate a debuginfo package.  Since I'm building
> with mock I don't think I can reasonably just edit macros.scl to
> temporarily work around this.
> 
> Anybody have any suggestions?
> 
> Many thanks it advance,
> 
> Paul


Hi Paul,
what version of scl-utils are you using? Historically, it was not possible to 
disable debug packages, it has only been fixed in one of the more recent 
versions ... 

Thanks
Jan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]