[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [scl.org] SCLo el6 packages have wrong upgrade path



On 10/22/2015 12:52 PM, Karanbir Singh wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 22/10/15 06:39, Honza Horak wrote:
So far I've just roughly looked at whether el6 SCL packages
available at http://mirror.centos.org/centos/6/SCL/x86_64/ properly
update to packages built in CBS, as we touched it yesterday. Long
story short, there are packages with higher NVR than what we have
in CBS now.

There are basically two options here -- we may rebuild the
problematic packages and bump release in CBS or we can document how
to properly update using `yum distro-sync`.

Anybody has a strong opinion about one of them?

 From my PoV, bumping&rebuilding should avoid more issues on users'
side, because we can't be sure what happens if packages are
combined (some from CBS and some from older repo) and depending on
manual step won't work in 100% cases.

Honza

do we know why the versions are newer ? is the corrosponding code also
newer ?

I didn't check many packages, but the difference was only in release, so I expect there were issues during build and release was bumped because of that. But we should check whether the content is really the same. Not done so far.

Honza

- --
Karanbir Singh, The CentOS Project, London, UK
RH Ext. 8274455 | DID: 0044 207 009 4455
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.22 (GNU/Linux)

iQEcBAEBAgAGBQJWKL/wAAoJEI3Oi2Mx7xbtq84H/2XSWBrrCTg7CExHk6Sgfg+O
FQuNKwhr7RPyZS94ZsHppNR208aRuX50eITW7fiExZAOtNSyUZyyjbQu0KXBID9E
hvBWWryYIfrLvGf0hU+f++dbWJo8Dk9Zse8oeaP+4Si6L3GZkIvZOl7UntBZgls4
bAubyEv2tkthR1BKmiLrjI1rnIBF7Sw04wv0n3eMKUfEvDfVghnjbKuvROOmrfl7
X04je+wJE1V1mBbX9ZhG2gF1ubF+lOLFE9N0ok5JGAfXXd7CVUTpts+SirpjQFL+
tk1dg8m3jxQpmucmMGONGZa3exvoEj/gQ3hdiANa1y2PMprvAR8cs0jfRmW9yoQ=
=irb7
-----END PGP SIGNATURE-----



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]