[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [scl.org] problems with rebuilding devtoolset-4 (tycho on centos7)



Hi,

On Wed, 2015-12-23 at 14:36 +0100, Honza Horak wrote:
> We have some issues with packages devtoolset-4-tycho and 
> devtoolset-4-sqt-chart when trying to rebuild devtoolset-4 in centos.
> 
> For centos 6 it went ok, for centos7 we see build errors once we set 
> %bootstrap macro to 0:
> 
> http://cbs.centos.org/koji/taskinfo?taskID=61162

It looks like java-1.8.0-openjdk-devel is being used during the build:
[ERROR] Command line
was: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.65-3.b17.el7.x86_64/jre/../bin/javadoc @options @packages

JDK8 is more strict than JDK7 when generating javadocs and I think this
causes the problem here.

The problem is that both JDK7 and JDK8 are in the buildroot and since
September of the last year, JDK8 has higher priority than JDK7
("alternatives" are involved).

The workaround could be to build the package with older
java-1.8.0-openjdk (java-1.8.0-openjdk-1.8.0.60-2.b27) in the buildroot.
Is untagging an option?

Regards,
Michal

> 
> I suspect the tycho being not properly build without bootstrap can cause 
> also the swt-chart build error:
> 
> http://cbs.centos.org/koji/taskinfo?taskID=61178
> 
> Except many errors in tycho build log like this:
> 
> [INFO] Tycho (Incubation) ................................ FAILURE [10.901s]
> 
> ...
> 
> [ERROR] public File getLocation();
> [ERROR] ^
> [ERROR] 
> /builddir/build/BUILD/org.eclipse.tycho-tycho-0.23.0/tycho-bundles/org.eclipse.tycho.embedder.shared/src/main/java/org/eclipse/tycho/ArtifactDescriptor.java:34: 
> error: unknown tag: TODO
> [ERROR] * @TODO should come from separate ReactorArtifactDescriptor
> [ERROR] ^
> [ERROR] 
> /builddir/build/BUILD/org.eclipse.tycho-tycho-0.23.0/tycho-bundles/org.eclipse.tycho.embedder.shared/src/main/java/org/eclipse/tycho/ArtifactDescriptor.java:36: 
> warning: no @return
> 
> ...
> 
> I see some suspicious error before:
> 
> ...
> 
> [INFO] Mojo extractor for language: java-annotations found 11 mojo 
> descriptors.
> line 2 column 68 - Error: plugin is not recognized!
> 
> ...
> 
> Not sure if this ^ one is causing the troubles though.
> 
> Full build log is available at:
> http://cbs.centos.org/kojifiles/work/tasks/1164/61164/build.log
> 
> I'd be very glad for any help, because I'm already out of ideas.
> 
> Honza
> 
> _______________________________________________
> SCLorg mailing list
> SCLorg redhat com
> https://www.redhat.com/mailman/listinfo/sclorg



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]