[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [scl.org] problems with rebuilding devtoolset-4 (tycho on centos7)



On 01/07/2016 07:43 AM, Petr Pisar wrote:
> On Wed, Jan 06, 2016 at 11:27:27PM +0100, Honza Horak wrote:
>> I've tried my luck and this commit:
>> https://github.com/sclorg-distgit/tycho/commit/36c6193ddac8bf6398418d0afb950cdaebd2bd64
>>
>> works:
>> https://cbs.centos.org/koji/taskinfo?taskID=62987
>>
>> I'm not entirely sure whether it is the correct fix to use though.

This patch looks correct.

IMHO the preferred long-term fix would be backporting the following
upstream XMvn patch to maven30-xmvn, which effectively does the same
thing, but affects all packages built with Maven:

  https://github.com/mizdebsk/xmvn/commit/a9cde0b

> Does that mean you still uses JDK 1.8 to compile the code? I worry that the
> bytecode is not backward compatible and you could encounter problems with
> running the code using JRE 1.7.

This shouldn't be a problem. First, most projects specify target
execution environment and Maven generates bytecode in this specific
version. If target is not specified then it defaults to 1.5. Secondly,
tycho is a Maven plugin - it is used only for building other packages.

-- 
Mikolaj Izdebski
Software Engineer, Red Hat
IRC: mizdebsk


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]