[scl.org] sclo-vagrant1 1.8.1 builds

Honza Horak hhorak at redhat.com
Tue May 17 18:34:48 UTC 2016

There is a test that has been running for every new build, but the test 
itself keeps failing (never worked properly imho). You might want to 
fix/rewrite it, so you can easily check status of every rebuild:

results are then in


On 05/17/2016 06:27 PM, Tomas Hrcka wrote:
> On 05/17/2016 05:21 PM, Dominic Cleal wrote:
>> A new sclo-vagrant1-vagrant build appeared today,
>> sclo-vagrant1-vagrant-1.8.1-4.el7, but it doesn't seem to be working
>> well with plugins built with 1.7.4-3.el7 as the root Vagrant
>> installation path changed.
> Sorry for the inconvenience, this has to slip through my hands.
>> It looks like %{vagrant_dir} has expanded differently, causing the root
>> of the Vagrant installation to be at
>> /opt/rh/sclo-vagrant1/root/usr/share/sclo-vagrant1-vagrant/ rather than
>> /opt/rh/sclo-vagrant1/root/usr/share/vagrant/.
>> 1.7.4-3.el7: http://cbs.centos.org/koji/rpminfo?rpmID=23881
>> 1.8.1-4.el7: http://cbs.centos.org/koji/rpminfo?rpmID=56779
>> The file /usr/lib/rpm/macros.d/macros.vagrant.sclo-vagrant1 in the older
>> build contains "%vagrant_dir %{_datadir}/vagrant", but the newer build
>> uses %{name} which expands to the SCLed name.
> I have fixed it back to pkg_name
>> This breaks builds of vagrant-libvirt which have scriptlets built using
>> %vagrant_plugin_register pointing to ../usr/share/vagrant, and new
>> builds of plugins (http://cbs.centos.org/koji/buildinfo?buildID=11111)
>> are being built with plugin names in the same place, e.g.
>> usr/share/sclo-vagrant1-vagrant-openstack-provider/lib.
>> thrcka, it looks like your build, could you look at this please?
>> Separately I've requested that sclo-vagrant1 be added to the sclo
>> testing repo via https://bugs.centos.org/view.php?id=10869 so I could
>> test the OpenStack package, but we should use the testing repo and
>> process once it's available to check updates work.
>> Also one final point, I couldn't find the source for the update in
>> https://github.com/sclorg-distgit/vagrant/tree/sig-sclo7-sclo-vagrant1-sclo
>> - could the changes be pushed there?
> Sorry I have opened pull request instead of pushing there. Changes are
> now pushed.
>> Cheers,
> _______________________________________________
> SCLorg mailing list
> SCLorg at redhat.com
> https://www.redhat.com/mailman/listinfo/sclorg

More information about the SCLorg mailing list