[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [scl.org] Can't install SCL



Hi Pavel,

Thanks for this. I can install devtoolset-4-gcc-c++.x86_64 fine, but to use it I run

scl enable devtoolset-4 <command> 

and that's what fails. 

On Thu, Aug 2, 2018 at 4:06 PM, Pavel Valena <pvalena redhat com> wrote:
----- Original Message -----
> From: "Mohan Ganesalingam" <mohan what3words com>
> To: sclorg redhat com
> Sent: Thursday, August 2, 2018 4:54:07 PM
> Subject: [scl.org] Can't install SCL
>
> I've just been trying to install SCL (in docker's centos:6 image), like so:
>
> docker run -it centos:6 /bin/bash
> yum -y update && yum install -y centos-release-scl

I think centos-release-scl will just install the repos for you.

> scl
>
> I get back /bin/sh: scl: command not found
>
> I've tried looking for scl with find, with no luck. This used to work
> (a few days ago)... I've been using it in CI for a while. Any help
> would be much appreciated...
>

Try installing some actual SCL, f.e.:

  $ sudo yum install rh-ruby24

https://www.softwarecollections.org/en/scls/rhscl/rh-ruby24/


HIH,

--
Pavel Valena
Software Engineer, Red Hat
Brno, Czech Republic


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]