[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[scl.org] Outdated package rh-python36 (2.0-1.el7)?



Hi,

I am somewhat confused by the content of python36 in version 2.0-1.el7 from centos-sclo-rh.

I am experiencing a bug similar to https://bugzilla.redhat.com/show_bug.cgi?id=1497342. The page says the bug was fixed in python-3.6.3-3.el7 python-3.6.3-3.el6.
This version numbering seems to relate to another repo. I found a python36 package matching this version in epel, installed it and saw everything working.

However, this is not because the bug in the patched version of hashlib (https://github.com/fedora-python/python36/blob/master/00146-hashlib-fips.patch) was fixed but because an unpatched version of hashlib is installed when using the epel package.
In the linked repo's epel7 branch this patch has been removed. python36 from centos-sclo-rh still ships the buggy patch.

Is this intentional? 

Cheers,

Matt

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]