[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [scl.org] MariaDB-10.5.9 package required in repo- rhscl for RHEL7.9



Hi Jan,
 
Thanks for reaching out‼
 
I had upgraded the mariadb from 5.5 to 10.3.27 on RHEL 7.9. I just need the latest stable release of mariadb on rhscl repo.
 
I tried to execute the steps given by you, however no luck!!
 
[root pcaveIPNDprx1 ~]# yum install rh-mariadb105
Loaded plugins: changelog, langpacks, product-id, search-disabled-repos, subscription-manager
rhel-7-server-rpms                                                                       | 2.0 kB  00:00:00    
rhel-server-rhscl-7-rpms                                                                 | 2.0 kB  00:00:00    
(1/4): rhel-7-server-rpms/7Server/x86_64/updateinfo                                      | 3.9 MB  00:00:00    
(2/4): rhel-server-rhscl-7-rpms/7Server/x86_64/updateinfo                                | 1.1 MB  00:00:00    
(3/4): rhel-server-rhscl-7-rpms/7Server/x86_64/primary                                   | 4.0 MB  00:00:00    
(4/4): rhel-7-server-rpms/7Server/x86_64/primary                                         |  51 MB  00:00:02    
rhel-7-server-rpms                                                                                  31775/31775
rhel-server-rhscl-7-rpms                                                                            13120/13120
No package rh-mariadb105 available.
Error: Nothing to do
[root pcaveIPNDprx1 ~]# scl enable rh-mariadb105 -- $SHELL
Unable to open /etc/scl/conf/rh-mariadb105!
 
=====================================================================================
 
I used below repo= rhel-server-rhscl-7-rpms earlier to upgrade the mariadb successfully to 10.3.27. Can we add the 10.5.8 or 10.5.9 to this repo please?
 
[root yahoovahoo ~]# yum --disablerepo="*" --enablerepo="rhel-server-rhscl-7-rpms" install rh-mariadb103-mariadb-*
Loaded plugins: changelog, langpacks, product-id, search-disabled-repos, subscription-manager
rhel-server-rhscl-7-rpms                                                                    | 2.0 kB  00:00:00    
Package 3:rh-mariadb103-mariadb-server-10.3.27-1.el7.x86_64 already installed and latest version
Package 3:rh-mariadb103-mariadb-errmsg-10.3.27-1.el7.x86_64 already installed and latest version
Package 3:rh-mariadb103-mariadb-10.3.27-1.el7.x86_64 already installed and latest version
Package 3:rh-mariadb103-mariadb-config-10.3.27-1.el7.x86_64 already installed and latest version
Package 3:rh-mariadb103-mariadb-server-utils-10.3.27-1.el7.x86_64 already installed and latest version
Package 3:rh-mariadb103-mariadb-common-10.3.27-1.el7.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package rh-mariadb103-mariadb-backup.x86_64 3:10.3.27-1.el7 will be installed
---> Package rh-mariadb103-mariadb-backup-syspaths.x86_64 3:10.3.27-1.el7 will be installed
.
.
.
.
Installed:
  rh-mariadb103-mariadb-backup.x86_64 3:10.3.27-1.el7                                                             
  rh-mariadb103-mariadb-backup-syspaths.x86_64 3:10.3.27-1.el7                                                    
  rh-mariadb103-mariadb-config-syspaths.x86_64 3:10.3.27-1.el7                                                    
  rh-mariadb103-mariadb-connect-engine.x86_64 3:10.3.27-1.el7                                                     
  rh-mariadb103-mariadb-devel.x86_64 3:10.3.27-1.el7                                                              
  rh-mariadb103-mariadb-gssapi-server.x86_64 3:10.3.27-1.el7                                                      
  rh-mariadb103-mariadb-java-client.noarch 0:2.4.1-2.el7                                                          
  rh-mariadb103-mariadb-java-client-javadoc.noarch 0:2.4.1-2.el7                                                  
  rh-mariadb103-mariadb-oqgraph-engine.x86_64 3:10.3.27-1.el7                                                     
  rh-mariadb103-mariadb-server-galera.x86_64 3:10.3.27-1.el7                                                      
  rh-mariadb103-mariadb-server-galera-syspaths.x86_64 3:10.3.27-1.el7                                             
  rh-mariadb103-mariadb-server-syspaths.x86_64 3:10.3.27-1.el7                                                    
  rh-mariadb103-mariadb-server-utils-syspaths.x86_64 3:10.3.27-1.el7                                              
  rh-mariadb103-mariadb-syspaths.x86_64 3:10.3.27-1.el7                                                           
  rh-mariadb103-mariadb-test.x86_64 3:10.3.27-1.el7                                                               
 
Dependency Installed:
  copy-jdk-configs.noarch 0:3.3-10.el7_5          java-1.8.0-openjdk-headless.x86_64 1:1.8.0.282.b08-1.el7_9      
  javapackages-tools.noarch 0:3.4.1-11.el7        lksctp-tools.x86_64 0:1.0.17-2.el7                              
  pcsc-lite-libs.x86_64 0:1.8.8-8.el7             python-javapackages.noarch 0:3.4.1-11.el7                       
  rh-mariadb103-Judy.x86_64 0:1.0.5-14.el7        rh-mariadb103-galera.x86_64 0:25.3.31-1.el7                     
  tzdata-java.noarch 0:2021a-1.el7              
 
Complete!
 
Thanks & Regards,
Pramod Tomar
+61-413189762
 
-----Original Message-----
From: Jan Staněk <jstanek redhat com>
Sent: Tuesday, 11 May 2021 8:48 PM
To: Tomar, Pramod <Pramod Tomar team telstra com>
Cc: sclorg redhat com
Subject: Re: [scl.org] MariaDB-10.5.9 package required in repo- rhscl for RHEL7.9
 
[External Email] This email was sent from outside the organisation – be cautious, particularly with links and attachments.
 
Hi,
I'm not sure what you want to do.
 
1.  If you want to install the "official" MariaDB RPMs provided by
    MariaDB foundation, reach to them for support – not really anything
    we can help you with there.
 
2.  If you want to use rhscl RPMs for MariaDB, there is rh-mariadb105
    collection, which currently include version 10.5.8.
    Use that as any other collection:
 
        # yum install rh-mariadb105
        # scl enable rh-mariadb105 -- $SHELL
 
Hope this helps!
--
Jan Staněk
Software Engineer, Red Hat
jstanek redhat com   irc: jstanek
 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]